Werbung / Banner buchen
Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: modified eCommerce Shopsoftware 2.0.7.2 rev 14622 veröffentlicht

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 45.568
    • Geschlecht:
    [ Für Gäste sind keine Dateianhänge sichtbar ]

    Wir sind stolz euch heute unsere Shopversion 2.0.7.2 rev 14622 mit einigen wichtigen Korrekturen präsentieren zu dürfen! :!:

    Wenn euch unser Engagement und die Shopsoftware gefällt, dann freuen wir uns über eine finanzielle Unterstützung, da diese in der Vergangenheit doch sehr stark zurück gegangen ist!


    Folgende Änderungen sind enthalten (Auszug aus dem Changelog):

    Zitat
    Seit modified eCommerce Shopsoftware 2.0.7.2
    - Fix #1820 Update Smarty
    - Fix #2259 Fehler beim Editieren von Bestellungen mit PHP 8
    - Fix #2261 Installer zeigt unnötiges DB Update an
    - Fix #2262 Nach Update auf 2.0.7.1 Hinweis auf /admin/start.php, dass DB nicht aktuell
    - Fix #2263 2.0.7.1 installer erstellt langes mod_installer_warning log
    - PayPal aktualisiert
    - Update Version Check
    - Update-Seite überarbeitet
    - Installer überarbeitet
    - Bugfixing

    Achtung: Seit Shopversion 2.0.7.0 rev 14473 setzen wir mindestens PHP 7.4 voraus! :!:

    Allgemeiner Hinweis, da nach jedem Update immer wieder Probleme gemeldet werden, die auf FTP-Übertragungsfehler zurück zu führen sind:

    Bitte beachtet beim Upload mittels FileZilla unten den Reiter "Fehlgeschlagene Übertragungen"! Dort werden alle Dateien aufgelistet, die nicht übertragen werden konnten. Diese dann alle markieren und mit Rechtsklick wieder zur Warteschlange hinzufügen und im Reiter "Zu übertragende Dateien" dann ebenfalls per Rechtsklick die Warteschlange erneut abarbeiten! Das macht ihr so lange, bis keine fehlgeschlagenen Übertragungen mehr im Reiter "Fehlgeschlagene Übertragungen" zu finden sind!

    WICHTIGE Korrekturen für Shopversion 2.0.7.2:
    Sollte es wichtige, nachträglich veröffentliche Korrekturen geben, werden diese hier bekannt gegeben.
    An dieser Stelle sei auch nochmal an unser gedrucktes Handbuch für Shopbetreiber erinnert:

    Das Handbuch richtet sich an alle aktuellen und zukünftigen Shopbetreiber, die modified eCommerce Shopsoftware im Detail kennenlernen möchten und eine fundierte Anleitung für die tägliche Arbeit mit dem Adminbereich wünschen.

    Mit dem Kauf dieses Handbuchs bekommt der Leser eine detaillierte, intuitive Anleitung, einen Demoshop Schritt für Schritt selbst zu erkunden und unterstützt damit gleichzeitig das Projekt. Programmierkenntnisse sind für das Verständnis dieses Handbuchs nicht erforderlich.

    Die Autorin (christel-pohl.de) arbeitet seit mehr als 14 Jahren freiberuflich als Layouter und Betreuerin von Gewerbetreibenden mit Internetshops. Durch die Erfahrung aus dieser Arbeit legt sie Wert auf einen leicht verständlichen Schreibstil mit möglichst wenig Fachausdrücken, damit auch Laien schnell zu einem Erfolgserlebnis gelangen.

    Die Druckausgabe beinhaltet 324 Seiten im Format DIN A5 Softcover.

    Das Buch ist im Buchhandel unter der ISBN: 978-3-7418-5676-1 und direkt bei der Autorin erhältlich: Klick mich!

    Quelle: Gedrucktes "Handbuch für Shopbetreiber" veröffentlicht

    Helft uns, diese Meldung zu verbreiten, und teilt es auf Facebook, twittert, blogt oder emailt es euren Freunden und Bekannten.

    Ein "Mobile First" responsive Template ist nun im Shop enthalten.

    Weitere Templates sind bei uns im Shop erwerblich.

    Wir wünschen euch viel Spaß mit der neuen Version und freuen uns auf euer Feedback.

    Bitte beachtet die Textdateien im Ordner "bitte_erst_lesen"!

    Der Download ist wie gewohnt auf der Download-Seite zu finden.

    Bitte bewertet unsere modified eCommerce Shopsoftware bei heise.de.

    Wenn euch die Shopsoftware gefällt, dann freuen wir uns über ein wenig finanzielle Unterstützung.

    Wir wünschen euch viel Erfolg bei der Umsetzung eurer Shop-Projekte mit der modified eCommerce Shopsoftware.

    Das modified eCommerce Shopsoftware Team

    [EDIT Tomcraft 23.08.2022: Korrekturen ergänzt.]
    [EDIT Tomcraft 03.10.2022: Korrektur changeset_14643.zip (siehe Ticket #2273) ergänzt.]

    Linkback: https://www.modified-shop.org/forum/index.php?topic=42438.0

    voodoopupp

    • Fördermitglied
    • Beiträge: 1.726
    • Geschlecht:
    Na jetzt aber!

    Top, wie ihr hier die Updates nachlegt. :thumbs:

    Vielen Dank für euren Einsatz.

    Timm

    • Fördermitglied
    • Beiträge: 5.575
    DANKE

    Großartig, wie schnell nachgebssert wurde. Update lief in meinem Testshop problemlos durch. Gibt zwar noch einiges an warnings im Installer, aber das hab ich im Ticket ergänzt.

    80% Tickets eines Users wird's wohl so schnell nicht noch mal geben. :hobbyhorse:

    Gruß Timm

    Timm

    • Fördermitglied
    • Beiträge: 5.575
    Moin

    Wenn ich in /lang/german/admin/check_update.php folgendes finde

    Code: PHP  [Auswählen]
    define('ERROR_CORRUPTED_FILE', 'Datei konnte nicht entpackt werden');
    define('ERROR_CREATE_DIRECTORY', 'Verzeichnis konnte nicht erstellt werden');
    define('ERROR_UPDATE_NOT_POSSIBLE', 'Automatisches Update nicht möglich');

    dann gehe ich davon aus, dass zukünftig automatische Updates von modified Modulen möglich sein werden. Das wäre ja der Hammer. Wird das alle ohne notwendige Templateänderungen betreffen?

    Gruß Timm

    GTB

    • modified Team
    • Gravatar
    • Beiträge: 5.998
    • Geschlecht:
    [...]
    Großartig, wie schnell nachgebssert wurde. Update lief in meinem Testshop problemlos durch. Gibt zwar noch einiges an warnings im Installer, aber das hab ich im Ticket ergänzt.
    [...]

    Du musst die Konfiguration über den Updater neu erstellen. Dann sind die Warnings auch weg.

    Gruß Gerhard

    esoversum

    • Fördermitglied
    • Beiträge: 104
    • Geschlecht:
    Top Top Top! :-B

    Wird gleich heute Abend drauf gespielt und getestet. :mrgreen:

    Danke für euren unermüdlichen Einsatz! :thumbs:

    GTB

    • modified Team
    • Gravatar
    • Beiträge: 5.998
    • Geschlecht:
    [...]
    dann gehe ich davon aus, dass zukünftig automatische Updates von modified Modulen möglich sein werden. Das wäre ja der Hammer. [...]

    Musst ja nicht gleich alles verraten.
    Das Grundsystem ist übrigens schon seit der 2.0.7.1 vorhanden.
    Wann wir das veröffentlichen ist noch offen. :nixweiss:

    Gruss Gerhard

    voodoopupp

    • Fördermitglied
    • Beiträge: 1.726
    • Geschlecht:
    :-X Pssssst!

    Timm

    • Fördermitglied
    • Beiträge: 5.575
    [...]
    Du musst die Konfiguration über den Updater neu erstellen. Dann sind die Warnings auch weg.
    [...]

    Was macht denn der Punkt "Konfiguration" genau? Vorher hieß er ja configure.php neu schreiben. Passiert da mehr, als diese Datei zu aktualisieren? Da die Datei nicht angepasst wurde im Shopupdate, hab ich den Punkt nicht ausgeführt.

    Ich hab in der Datei auch Änderungen für Redis. Das würde dann überschrieben und ich wüsste grad gar nicht, ob der Shop bzw der installer dann noch funktioniert, wenn er dort auf mysqli umstellt und im Shopbackend bei Cache Engine noch Redis steht. Zumal ich das danach wieder zurück  ändern müsste in der Datei.

    Gruß Timm

    P.S. Ich wollte nichts verraten. Da es im Updatepaket enthalten ist, dachte ich nicht, dass es ein Geheimnis ist. Zumindest nicht für die, die sich die Dateien auch genau anschauen.

    GTB

    • modified Team
    • Gravatar
    • Beiträge: 5.998
    • Geschlecht:
    Die Änderung für Redis habe ich dir ausgelagert.
    Damit kannst du die Konfiguration neu erstellen.

    Gruss Gerhard

    Timm

    • Fördermitglied
    • Beiträge: 5.575
    Danke dir.

    Jetzt ist mir aufgefallen, dass die "/includes/configure.php" sich doch geändert hat in der 2.0.7.1 Vollversion. Allerdings ist in keinem der Update-Pakete nach 2.0.5.1 diese Datei enthalten. Man kann das also nicht wissen, wenn man sich nur die Update-Pakete zieht und sich daraus einen Update-Ordner zusammenstellt.

    Insofern bringt es was im _installer die Konfiguration neu erstellen zu lassen. Jedoch ändert der _installer die configure.php nicht vollständig!

    Das require zu require_once wird geändert:

    Code: PHP  [Auswählen]
    // include standard settings
        require_once(DIR_FS_CATALOG.(defined('RUN_MODE_ADMIN')? DIR_ADMIN : '').'includes/paths.php');

    Aber das fehlt:

    Code: PHP  [Auswählen]
    // timezone
      defined('DEFAULT_TIMEZONE') or define('DEFAULT_TIMEZONE', 'Europe/Berlin');

    Gruß Timm

    Bruno-der-Zweite

    • Fördermitglied
    • Beiträge: 98
    • Geschlecht:
    Hallo,

    danke für das Update. Bei mir ist irgendwas durcheinander geraten, ich weiß nur nicht was. Der Shop läuft, es kommt aber immer die DB Warnung (siehe Bild) .

    Gruß
    Bruno

    Timm

    • Fördermitglied
    • Beiträge: 5.575
    Moin

    Schau mal was in "/admin/includes/version.php" steht.

    Wenn dort 2.0.7.1 steht, dann wirst du nicht alle Dateien korrekt hochgeladen haben bzw. hast ein umbenanntes admin-Verzeichnis und nicht in den umbenannten admin-Ordner kopiert.

    Gruß Timm

    Bruno-der-Zweite

    • Fördermitglied
    • Beiträge: 98
    • Geschlecht:
    Danke, das war`s - Warnmeldung ist weg.

    Gruß
    Bruno

    Timm

    • Fördermitglied
    • Beiträge: 5.575
    Wenn es noch die ältere Datei war, solltest du aber prüfen, ob es noch weitere fehlende Dateien gibt bzw. deinen Updateordner nochmals komplett hochladen.

    Gruß Timm
               
    anything