Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: Kein Einloggen als Admin und keine Anlage registrierter Kunden mehr möglich

    Jummy

    • Neu im Forum
    • Beiträge: 27
    In meinem Shop www.macbrite-shop.com (v2.0.5.1 rev 12725, Datenbank Version: "MOD_2.0.5.1" und Bootstrap 4 Template) kann ich mich plötzlich nicht mehr als Admin anmelden und bei der Neuanlage registrierter Kunden kann man die Daten in der Maske zwar eintragen aber diese werden nicht in die DB übernommen.

    Das übliche Procedere:
    cache
    template_c löschen

    admin_access:  customers_id = 0 alle anderen Werte = 1
    customers:  customers_id=0   |   customers_status=0

    wurde erledigt.

    Interessant ist ferner, daß wenn ich bei  'Passwort vergessen' das CAPTCHA eingebe, obwohl dies richtig eingegeben worden ist, immer wieder ein neues CAPTCHA kommt..

    Bin für jeden Hinweis dankbar.

    Linkback: https://www.modified-shop.org/forum/index.php?topic=41662.0
    Händlerbund_728x90_animiert

    GTB

    • modified Team
    • Gravatar
    • Beiträge: 5.584
    • Geschlecht:
    Da läuft eine Umleitung !
    Entweder beim Hoster eingetragen oder in der htaccess.

    Gruss Gerhard

    Jummy

    • Neu im Forum
    • Beiträge: 27
    Grüß Gott Gerhard,

    recht herzlichen Dank für Deine schnelle Hilfe, Du hast unser Problem gelöst.

    Viele Grüße

    Jürgen

    GTB

    • modified Team
    • Gravatar
    • Beiträge: 5.584
    • Geschlecht:
    Hallo,

    wenn du noch mehr Details scheiben könntest, was bei dir den Fehler verursacht hat, kannst du anderen damit helfen.

    Gruss Gerhard

    Jummy

    • Neu im Forum
    • Beiträge: 27
    Hallo Gerhard,
    Sorry habe Deinen Post erst jetzt gelesen.
    Ich habe damals entfernt:

    ## hinzugefuegt durch admin
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www.macbrite-shop.com$
    RewriteRule ^(.*)$ http://www.macbrite-shop.com/$1 [R=301,L]
    ##

    Dies war am 9.2. und Anmeldung als Admin war wieder möglich.

    Heute wollte ich mich wieder als Admin anmelden und das ursprgl. Problem ist erneut aufgetreten.

    FEHLER: Keine Übereinstimmung der eingegebenen 'E-Mail-Adresse' und/oder dem 'Passwort'.
    Ihr eingegebener Sicherheitscode stimmte nicht mit dem angezeigten Code überein. Bitte versuchen Sie es erneut.


    Die .htaccess kann sich doch nicht selbst verändern oder doch ? Dateiberechtigungen sind auf 644 gesetzt.

    Gibt es denn eine Minimal .htaccess , die ich verwenden könnte.

    Jummy

    • Neu im Forum
    • Beiträge: 27
    -Teilerfolg!

    In der Tabelle: customers war der Eintrag für den Admin nicht mehr enthalten. (Wir haben den sicherlich nicht gelöscht !?)
    Habe einen neuen Eintrag erstellt und komme jetzt zwar in das Adminmenü kann aber im Topmenü:

    Start | Kunden | Katalog | Module | Partner Module |  etc.

    keine Auswahl treffen.

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.427
    Moin

    Dir fehlen in der .htaccess die Weiterleitungen auf https. Da müssen die Rauten bei der bevorzugten Variante (ob Domain mit oder ohne www) entfernt werden.

    Wie sind die Serverpfade In includes/configure.php angegeben? Wenn man nämlich in deinem Shop auf einen Link klickt, dann wird der ohne https://www aufgerufen.

    Poste am besten den Inhalt der .htacces in Codetags und den Teil der configure.php. Bitte drauf achten, dass du keine DB Zugangsdaten mit postest.

    Hier noch die SSL Anleitung aus dem WIKI

    Gruss Timm

    Jummy

    • Neu im Forum
    • Beiträge: 27
    Hallo Timm

    danke für Deine Antwort.

    Im Anhang die .htaccess als txt.
    Das mit der includes/configure.php sehe ich mir zunächst mal selber an, dann brauche ich Deine Zeit dafür nicht zu beanspruchen.

    Gruß

    Jürgen

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.427
    Moin

    Wenn es https://www.example.com sein soll, dann ändere

    Code: XML  [Auswählen]
      ##-- redirect to https www-domain, when www is missing and no subdomain given and not using an ssl-proxy
      #RewriteCond %{HTTP_HOST} !^www\. [NC]
      #RewriteCond %{HTTP_HOST} !\.(.*)\. [NC]
      #RewriteCond %{HTTP_HOST} !^localhost [NC]
      #RewriteRule ^ https://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
      #RewriteCond %{SERVER_PORT} !^443$
      #RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
     

    zu

    Code: XML  [Auswählen]
      ##-- redirect to https www-domain, when www is missing and no subdomain given and not using an ssl-proxy
      RewriteCond %{HTTP_HOST} !^www\. [NC]
      RewriteCond %{HTTP_HOST} !\.(.*)\. [NC]
      RewriteCond %{HTTP_HOST} !^localhost [NC]
      RewriteRule ^ https://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
      RewriteCond %{SERVER_PORT} !^443$
      RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
     

    wenn nur https://example.com, dann ändere

    Code: XML  [Auswählen]
      ##-- redirect to https non-www-domain, when no subdomain given and not using an ssl-proxy
      #RewriteCond %{SERVER_PORT} !^443$ [OR]
      #RewriteCond %{HTTP_HOST} ^www\. [NC]
      #RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
      #RewriteRule ^ https://%1%{REQUEST_URI} [R=301,L]
     

    zu

    Code: XML  [Auswählen]
      ##-- redirect to https non-www-domain, when no subdomain given and not using an ssl-proxy
      RewriteCond %{SERVER_PORT} !^443$ [OR]
      RewriteCond %{HTTP_HOST} ^www\. [NC]
      RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
      RewriteRule ^ https://%1%{REQUEST_URI} [R=301,L]
     

    Aber bitte nur für eine der beiden Varianten entscheiden  ;-)

    Solltest du den Shop als Utf-8 installiert haben, dann ganz oben noch

    Code: XML  [Auswählen]
    ##-- Default charset
    #AddDefaultCharset UTF-8
    AddDefaultCharset ISO-8859-15
     

    ändern zu

    Code: XML  [Auswählen]
    ##-- Default charset
    AddDefaultCharset UTF-8
    #AddDefaultCharset ISO-8859-15
     

    Und dann wäre noch die Frage, ob der unterste Teil bei dir sinnvoll/notwendig ist?

    Code: XML  [Auswählen]
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php73” package as the default “PHP” programming language.
    <IfModule mime_module>
      AddHandler application/x-httpd-ea-php73 .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
     

    Gruss Timm

    Jummy

    • Neu im Forum
    • Beiträge: 27
    Guten Abend Timm,

    recht herzlichen Dank für Deine Mühe.
    Ich werde die Änderungen vornehmen und dann weiter berichten.

    Gruß

    Jürgen
    4 Antworten
    1411 Aufrufe
    07. Februar 2018, 09:58:07 von Teratek
    17 Antworten
    5718 Aufrufe
    05. Januar 2017, 09:19:08 von Boergi
               
    anything