Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: modified eCommerce Shopsoftware 2.0.2.2 rev 10690 veröffentlicht

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 43.935
    • Geschlecht:
    [ Für Gäste sind keine Dateianhänge sichtbar ]

    Wir sind stolz euch heute unsere Shopversion 2.0.2.2 rev 10690 nach drei monatiger Entwicklungszeit präsentieren zu dürfen! :!:

    Wenn euch unser Engagement und die Shopsoftware gefällt, dann freuen wir uns über eine finanzielle Unterstützung, da diese in der Vergangenheit doch sehr stark zurück gegangen ist!


    Folgende Änderungen sind enthalten (Auszug aus dem Changelog):

    Zitat
    Seit modified eCommerce Shopsoftware 2.0.2.2
    - Update PHP Mailer auf Version 5.2.23
    - Update PayPal SDK auf Version 1.11.0
    - PayPal Zahlungsmodule aktualisiert
    - Fix #1144 PHP 7 Fix für session gc, session write close
    - Fix #1115 KCFinder
    - Fix #1155 products_new.php zeigte Artikel in anderen Sprache ohne Artikelnamen, wenn keiner angegeben war
    - Fix #1158 Anrede in Kontoeröffnungs-Email korrigiert
    - Fix #1159 CSS-Klassenangabe in Tabellenzeile für Download-Attribut korrigiert
    - Fix #1165 Lieferstatus Übersetzung korrigiert
    - Fix #1020 CSS- & JS-Komprimierung in Templates überarbeitet
    - Fix #1162 Unter bestimmten Umständen konnte es vorkommen, dass Kunden per PayPal versandkostenfrei einkaufen konnten
    - Update Bankleitzahlen
    - Update Shopgate Module auf Version 2.9.35
    - Update easybill Modul
    - Update billpay Zahlungsmodul
    - Update Klarna Zahlungsmodul
    - Update Trusted Shops Modul
    - Added missing language definition ab_update in templates
    - Diverse Code-Optimierungen und Fehlerkorrekturen

    Achtung: Seit Shopversion 2.0.2.0 rev 10591 setzen wir mindestens PHP 5.4 voraus! :!:

    An dieser Stelle sei auch nochmal an unser gedrucktes Handbuch für Shopbetreiber erinnert:

    Das Handbuch richtet sich an alle aktuellen und zukünftigen Shopbetreiber, die modified eCommerce Shopsoftware im Detail kennenlernen möchten und eine fundierte Anleitung für die tägliche Arbeit mit dem Adminbereich wünschen.

    Mit dem Kauf dieses Handbuchs bekommt der Leser eine detaillierte, intuitive Anleitung, einen Demoshop Schritt für Schritt selbst zu erkunden und unterstützt damit gleichzeitig das Projekt. Programmierkenntnisse sind für das Verständnis dieses Handbuchs nicht erforderlich.

    Die Autorin (christel-pohl.de) arbeitet seit mehr als 14 Jahren freiberuflich als Layouter und Betreuerin von Gewerbetreibenden mit Internetshops. Durch die Erfahrung aus dieser Arbeit legt sie Wert auf einen leicht verständlichen Schreibstil mit möglichst wenig Fachausdrücken, damit auch Laien schnell zu einem Erfolgserlebnis gelangen.

    Die Druckausgabe beinhaltet 324 Seiten im Format DIN A5 Softcover.

    Das Buch ist im Buchhandel unter der ISBN: 978-3-7418-5676-1 und direkt bei der Autorin erhältlich: Klick mich!

    Quelle: Gedrucktes "Handbuch für Shopbetreiber" veröffentlicht

    Helft uns, diese Meldung zu verbreiten, und teilt es auf Facebook, twittert, blogt oder emailt es euren Freunden und Bekannten.

    Ein responsive Template kann für 149€ netto über das Kontaktformular angefragt werden.

    Wer vorab schon mal einen Blick auf das Responsive Template machen möchte kann im Dev Demoshop schauen.

    Wir wünschen euch viel Spaß mit der neuen Version und freuen uns auf euer Feedback.

    Bitte beachtet die Textdateien im Ordner "bitte_erst_lesen"!

    Der Download ist wie gewohnt auf der Download-Seite zu finden.

    Bitte bewertet unsere modified eCommerce Shopsoftware bei heise.de.

    Wenn euch die Shopsoftware gefällt, dann freuen wir uns über ein wenig finanzielle Unterstützung.

    Wir wünschen euch viel Erfolg bei der Umsetzung eurer Shop-Projekte mit der modified eCommerce Shopsoftware.

    Das modified eCommerce Shopsoftware Team

    Linkback: https://www.modified-shop.org/forum/index.php?topic=37070.0
    Werbung / Banner buchen

    awids.de

    • Experte
    • Beiträge: 2.572
    • Geschlecht:
    :thx: Ein verfrühtes Ostergeschenk. :D

    Ich hätte mir an dieser Stelle schon weitere Hookpoints gewünscht, aber die gibt es wohl nur, wenn sich die 3. Stelle in der Versionsnummer (2.0.X.Y) ändert.  :mhhh:

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 3.479
    :thx:

    Muss am tpl_modified_responsive template etwas geändert werden?

    web28

    • modified Team
    • Beiträge: 9.404
    :thx:

    Muss am tpl_modified_responsive template etwas geändert werden?

    Einfach ins Update Paket schauen bei tpl_modified und diese Dateien mit den aus der vorherigen Version vergleichen. Dann sieht man die Änderungen und kann diese auch im eigenen Template übernehmen.

    Gruss Web28

    PS: Diese Version würde ich jetzt selber mit PHP 7 betreiben.  ;-)

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 43.935
    • Geschlecht:
    :thx:

    Muss am tpl_modified_responsive template etwas geändert werden?

    Du kannst jederzeit per E-Mail ein Update des responsive Templates bei mir anfragen.

    Grüße

    Torsten

    p3e

    • Experte
    • Beiträge: 2.134
    Neue Versionen kommen gerne, wenn ich gerade im Urlaub bin ;)
    Danke und schöne Ostertage an das Team!

    sieghard

    • Fördermitglied
    • Beiträge: 33
    • Geschlecht:
    Vielen Dank für eure gute Arbeit, das Update auf die 2.0.2.2 r10690 hat problemlos funktioniert!  :thx:

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 3.479
    PS: Diese Version würde ich jetzt selber mit PHP 7 betreiben.  ;-)

     :thumbs:

    :thx:

    Muss am tpl_modified_responsive template etwas geändert werden?

    Du kannst jederzeit per E-Mail ein Update des responsive Templates bei mir anfragen.

    Grüße

    Torsten

     :thumbs: You got mail.

    Mike Randoo

    • Fördermitglied
    • Beiträge: 177
    • Geschlecht:
    Ein großes Danke für Eure unermüdliche Arbeit und schöne Ostertage!  :cheers:

    michaelEberl

    • Mitglied
    • Beiträge: 111
    Danke für Eure Arbeit.
    Michael

    Mike Randoo

    • Fördermitglied
    • Beiträge: 177
    • Geschlecht:
    Hallo web28,
    kurze Frage hierzu:

    Zitat
    PS: Diese Version würde ich jetzt selber mit PHP 7 betreiben.  ;-)

    Ist es ausreichend, den Shop auf die letzte, gestrige Version zu updaten und anschließend den Server auf PHP7 umzustellen? Oder muss für die Umstellung der PHP-Version noch mehr gemacht werden?

    Danke und Gruß,
    Mike

    Modulfux

    • Experte
    • Beiträge: 3.590
    • Geschlecht:
    BUG im Template:
    Durch das str_replace von type="text" zu type="email" kommen die Eingabefelder vom Typ email ohne Stylesheets daher. Eine Erweiterung der vorhanden Styles für die input[type=xxx] bringt Abhilfe.

    Gruß
    Ronny

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 43.935
    • Geschlecht:
    Oh das war ein versehen, danke für den Hinweis! :thx:

    Die Erweiterung des E-Mail Feldes sollte eigentlich nur in die responsive Templates, denn in den anderen macht der "replace" wenig Sinn.

    Abhilfe schafft in der Datei /templates/tpl_modified/module/login.html suchen:

    Code: PHP  [Auswählen]
    {$INPUT_MAIL|replace:"type=\"text\"":"type=\"email\""}

    und ersetzen mit:

    Code: PHP  [Auswählen]
    {$INPUT_MAIL}

    [...]
    Ist es ausreichend, den Shop auf die letzte, gestrige Version zu updaten und anschließend den Server auf PHP7 umzustellen? Oder muss für die Umstellung der PHP-Version noch mehr gemacht werden?
    [...]

    Das kann man pauschal nicht beantworten, da wir nicht wissen welche Module bei dir im Shop noch verbaut sind, die nicht mit PHP 7 kompatibel sind. Das selbe kann für Drittanbieter-Templates gelten.

    Grüße

    Torsten

    oneQ

    • Viel Schreiber
    • Beiträge: 585
    :thx: und frohe Osterfeiertage!

    Mike Randoo

    • Fördermitglied
    • Beiträge: 177
    • Geschlecht:
    @Torsten
    Wäre ja auch zu schön, wenn es mal einfach gewesen wäre ;-)
    Trotzdem danke für die Info. Werde bei den 2 Anbietern nachfragen, ob was gegen PHP7 spricht...

    Gruß,
    Mike
    anything