Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:

Autor Thema: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht  (Gelesen 14443 mal)

Offline GNLA

  • Neu im Forum
  • *
  • Beiträge: 12
  • Geschlecht: Männlich
    • Teile Beitrag
    • GNLA- Mobile Computing
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #60 am: 24. Januar 2017, 12:18:10 »
Danke es funkt wieder. bin wieder glücklich.

Wenn sich einer über das Forum oder Modified beschwert, erschiesst ihn! 
Gute Arbeit
  Danke nochmal

Offline usprenger

  • Neu im Forum
  • *
  • Beiträge: 2
    • Teile Beitrag
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #61 am: 24. Januar 2017, 13:53:41 »
[...]
Dann wurde bei dir die Datei "/admin/includes/application_top.php" nicht auf den FTP-Server geladen, denn dort steht die Konstante "DB_VERSION" offensichtlich noch auf "MOD_2.0.1.0".
[...]

Danke für die Info. Fast richtig, die Datei wurde ins falsche Verzeichnis kopiert. ;-)

Danke und Gruß

Ulli

Offline Martin109

  • Fördermitglied
  • *****
  • Beiträge: 194
  • Geschlecht: Männlich
    • Teile Beitrag
    • Bay-Tec Modelltechnik
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #62 am: 24. Januar 2017, 14:42:47 »
Guck mal ob in deiner templates/dein_template/source/boxes/specials.php das drin steht.

Code: PHP  [Auswählen]
defined('SPECIALS_CONDITIONS_S') or define('SPECIALS_CONDITIONS_S', 'AND s.status = \'1\'');

also das steht bei mir genau so drin.

Gruß Martin

Offline Tomcraft

  • modified Team
  • *****
  • Gravatar
  • Beiträge: 43.424
  • Geschlecht: Männlich
    • Teile Beitrag
    • https://www.modified-shop.org
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #63 am: 24. Januar 2017, 14:55:22 »
[...]
Ich nutze das Modified-Responisve Template.
Sind in dieses durch die 2.0.2.0 rev 10591 auch Updates mit eingeflossen?
[...]

Das hatte ich hier bereits mal beantwortet:

Eine aktuelle Version des responsive Templates kann von Käufern bei mir per E-Mail angefordert werden.

Ansonsten gilt weiterhin uneingeschränkt folgende Anleitung: Tutorial: Template eines xt:Commerce Shops in der modified eCommerce Shopsoftware weiter verwenden
[...]

Quelle: Ist tpl_modified Version 2.0.1.0 in Shopversion 2.0.2.0 noch zu verwenden?

Grüße

Torsten

Offline AllyG

  • Schreiberling
  • ****
  • Beiträge: 361
  • Geschlecht: Männlich
    • Teile Beitrag
    • Adrenalin-Fishing
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #64 am: 24. Januar 2017, 17:52:17 »
Huhu,

schreibt Torsten einfach mal an. Ich hab mein Template gestern auf 2.0.2 gebracht und es waren unter 20 Dateien, die verglichen werden mussten. Also kaum Arbeit. ;)

Offline Angeal

  • Fördermitglied
  • *****
  • Beiträge: 394
  • Geschlecht: Männlich
    • Teile Beitrag
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #65 am: 25. Januar 2017, 08:21:38 »
Hallo Zusammen,
bekomme seit dem Update auf 2.0.2.0 folgende Fehlermeldungen

Zitat
1054 - Unknown column 's.status' in 'where clause'

SELECT products_id,
specials_quantity
FROM specials
WHERE products_id = '257'
AND s.status = '1' AND (now() >= s.start_date OR s.start_date IS NULL)

Request URL: www.domain.de/checkout_process.php?paymentId=PAY-5WR08316BL095404HLCD4R3I&token=EC-7XY75403YN995904X&PayerID=HASS4VWT2DJYY

[XT SQL Error]

Zitat
1054 - Unknown column 's.status' in 'where clause'

SELECT products_id,
specials_quantity
FROM specials
WHERE products_id = '244'
AND s.status = '1' AND (now() >= s.start_date OR s.start_date IS NULL)

Request URL: www.domain.de/checkout_process.php?paymentId=PAY-5WR08316BL095404HLCD4R3I&token=EC-7XY75403YN995904X&PayerID=HASS4VWT2DJYY

[XT SQL Error]

Kann mir da jemand zu weiterhelfen?

Offline Modulfux

  • Experte
  • *****
  • Beiträge: 3.567
  • Geschlecht: Männlich
    • Teile Beitrag
    • Modulfux - die ultimative SEO-Url für modified

Offline Angeal

  • Fördermitglied
  • *****
  • Beiträge: 394
  • Geschlecht: Männlich
    • Teile Beitrag
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #67 am: 25. Januar 2017, 08:34:11 »
Danke dir :-)

Offline Martin109

  • Fördermitglied
  • *****
  • Beiträge: 194
  • Geschlecht: Männlich
    • Teile Beitrag
    • Bay-Tec Modelltechnik
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #68 am: 25. Januar 2017, 08:43:32 »
Guck mal ob in deiner templates/dein_template/source/boxes/specials.php das drin steht.

Code: PHP  [Auswählen]
defined('SPECIALS_CONDITIONS_S') or define('SPECIALS_CONDITIONS_S', 'AND s.status = \'1\'');

also das steht bei mir genau so drin.

Gruß Martin

Hat nicht noch jemand eine Idee?? bei mir kommt immer noch wenn  ich neue Produkte ansehen will diese Fehlermeldung per Mail.

Code: PHP  [Auswählen]
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'SPECIALS_CONDITIONS_S

'
at line 14

select count(DISTINCT p.products_id) as total FROM products p
LEFT JOIN manufacturers m
ON p.manufacturers_id = m.manufacturers_id
LEFT JOIN products_description pd
ON p.products_id = pd.products_id
AND pd.language_id = '2'
JOIN products_to_categories p2c
ON p.products_id = p2c.products_id
JOIN categories c
ON c.categories_id = p2c.categories_id
AND c.categories_status=1
LEFT JOIN specials s
ON p.products_id = s.products_id
SPECIALS_CONDITIONS_S

WHERE p.products_status = '1'
AND p.group_permission_1 = 1

Request URL: www.bay-toys.de/bay-toys-shop20/products_new.php

[XT SQL Error]

Gruß Martin

www.bay-toys.de

Offline Buggyboy

  • Fördermitglied
  • *****
  • Beiträge: 915
  • Geschlecht: Männlich
    • Teile Beitrag
    • Spiel-Zeit-Shop
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #69 am: 25. Januar 2017, 09:07:07 »
Moin!

Ich möchte heute mal meine Erfahrungen hier mit dem V2.0.2.0 mitteilen.

Ich hatte den V2.0.1.0 neu erstellt und meine alten Daten importiert (nur Produkte und Content,keine Benutzer).
Dann kam zwei Wochen später dieses Update raus.
Na toll dachte ich.Hab doch gerade alles soweit fertig ;-}

Update runtergeladen und entpackt.
Dann hab ich jede Datei mit der auf dem Webspace verglichen, ob ich da schon was verändert habe (sieht man ja meistens am Datum). Wenn nicht hab ich sie einfach überschrieben.
Wenn doch, hab ich erstmal die alte gesichert und die neue aufgespielt.
Dann hab ich nach den Änderungen geschaut.
Dank des neuen Autoinclude-Systems hielten sich die Änderungen in Grenzen.

Also alle auf den Webspace und dann das Template nach der Anleitung aus dem Wiki aufgebohrt.
Allerdings hab ich da nicht alles gemacht und auch ein paar Passagen nicht gefunden, welche man aber eh nur Optional verwenden konnte.

Danach den Installer aufgerufen. Dann erst die Dateien löschen lassen (ob die Liste so auch gelöscht wurde kann ich nicht sagen.Sind einfach zuviele Dateien die da drinn stehen)
Anschließend den zweiten Menüpunkt ausgeführt und im Anschluß den dritten mit dem SQL-Update.

Nach der Fertigstellung wieder einloggen... Auf meinem Xampp hat das gleich beim ersten mal geklappt... Dann gesehen, das die Umlaute nicht richtig übertragen wurden.
Von meiner 2.0.1.0 Datenbanksicherung hatte ich bei Phpmyadmin die Datenbank importiert. Da hats wohl irgendwas verhauen.
Also alle Tabellen geleert und dann die SQL Stück für Stück kopiert und eingefügt. Läuft...
Dann wieder alles auf den Webspace und SSL wieder eingestellt. Kein Admin Login.... Passwort zuschicken lassen. Läuft

Ich hoffe das wars jetzt erst einmal... ;-}

Hab dann auch gleich eine Spende (zwar nicht gross aber immerhin) an Torsten geschickt, da die 2.0.2.0 Version der Hammer ist.
Vieles ist zum Standard geworden und mit dem Auto-Include-System muß man später nicht mehr ganz soviel ändern bei einem Update.

Vielen Dank an das Team für diese tolle Software.

Mit verspielten Grüßen
Peter

Offline Martin109

  • Fördermitglied
  • *****
  • Beiträge: 194
  • Geschlecht: Männlich
    • Teile Beitrag
    • Bay-Tec Modelltechnik
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #70 am: 25. Januar 2017, 11:23:39 »
Guck mal ob in deiner templates/dein_template/source/boxes/specials.php das drin steht.

Code: PHP  [Auswählen]
defined('SPECIALS_CONDITIONS_S') or define('SPECIALS_CONDITIONS_S', 'AND s.status = \'1\'');

also das steht bei mir genau so drin.

Gruß Martin

Hat nicht noch jemand eine Idee?? bei mir kommt immer noch wenn  ich neue Produkte ansehen will diese Fehlermeldung per Mail.

Code: PHP  [Auswählen]
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'SPECIALS_CONDITIONS_S

'
at line 14

select count(DISTINCT p.products_id) as total FROM products p
LEFT JOIN manufacturers m
ON p.manufacturers_id = m.manufacturers_id
LEFT JOIN products_description pd
ON p.products_id = pd.products_id
AND pd.language_id = '2'
JOIN products_to_categories p2c
ON p.products_id = p2c.products_id
JOIN categories c
ON c.categories_id = p2c.categories_id
AND c.categories_status=1
LEFT JOIN specials s
ON p.products_id = s.products_id
SPECIALS_CONDITIONS_S

WHERE p.products_status = '1'
AND p.group_permission_1 = 1

Request URL: www.bay-toys.de/bay-toys-shop20/products_new.php

[XT SQL Error]

Gruß Martin

www.bay-toys.de

Herzlichen Dank an Ronny (Webkiste) er hat den Fehler gefunden. :-)
Es wahr wohl was beim Update von 2.0.1.0 auf 2.0.2.0 schiefgelaufen.

Aber nun geht es .

Vielen Vielen Dank nochmal.

Gruß Martin

Offline Ladiva

  • Fördermitglied
  • *****
  • Beiträge: 267
    • Teile Beitrag
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #71 am: 01. Februar 2017, 15:11:36 »
Zitat
WARNUNG: Ihre DB muss aktualisiert werden, bitte den Installer ausführen:

    DB muss von Release MOD_2.0.2.0 auf MOD_2.0.1.0 aktualisiert werden.

Hatte ich auch, bis ich bemerkte das der admin Ordner ja mittlerweile eine individuellen Namen hat..

Somit hatte ich dann die Änderungen in admin und der wo sie hinmüssten wäre admin_deineendung gewesen

Offline lachralle

  • Neu im Forum
  • *
  • Beiträge: 12
    • Teile Beitrag
Re: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht
« Antwort #72 am: 05. April 2017, 13:42:16 »
Moin,

eine tolle Software habt Ihr da entwickelt. Nach einigen Startschwierigkeiten mit dem Update war ich der Meinung, alles richtig gemacht zu haben. Nach dem Einloggen als Admin kommt aber folgender Hinweis, obwohl ich das richtige Update installiert habe:

Zitat
WARNUNG: Ihre DB muss aktualisiert werden, bitte den Installer ausführen:

    DB muss von Release MOD_2.0.2.0 auf MOD_2.0.1.0 aktualisiert werden.

Gruß Ulli

Möglicherweise hast Du denselben Fehler gemacht wie ich und die Admin Dateien aus dem Update nicht in den korrekten Admin Ordner auf dem Server kopiert, siehe: "DB muss von Release MOD_2.0.2.1 auf MOD_2.0.1.0 aktualisiert werden"?


Teile per facebook Teile per linkedin Teile per twitter