Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: modified eCommerce Shopsoftware 2.0.0.0 rev 9678 veröffentlicht

    jumpM

    • Fördermitglied
    • Beiträge: 686
    • Geschlecht:
    grrr... hat sich schon erledigt!!!!

    Sorry

    Robert

    TrueSlide

    • Schreiberling
    • Beiträge: 298
    Wieso machst Du einen Restore einer alten 1.06-DB in einen neuen 2.0-Shop? Genau da liegt Dein Fehler.

    Mach ein Restore der alten 1.06-DB und nutze diese DB dann für die Installation des neuen 2.0 Shops.

    Erklärung: Beim Update af 2.0 werden nicht nur PHP-Dateien geändert. Auch die Struktur der Datenbank hat Änderungen. Wenn Du die alte DB wieder zurücksicherst, sind die Änderungen aber nicht mehr da.

    Hört sich vielleicht doof an, aber gerade verstehe ich gerade wirklich nicht, was du meinst.  :-?
    Du fragst wieso ich einen Restore einer 1.06 DB mache, da darin mein Fehler liegt, schreibst dann aber, ich soll einen Restore der 1.06 machen und diese dann zur Installation nutzen!?!

    Normalerweise verstehe ich was gemeint ist, nur gerade und in diesem Fall stehe ich komplett auf'm Schlach.

    webald

    • modified Team
    • Beiträge: 2.713
    Richtig:
    Restore DB 1.06 => Update 2.0 => fertig

    Falsch:
    Update 2.0 => Restore DB 1.06 => Datenstruktur passt nicht zum neuen Shop

    TrueSlide

    • Schreiberling
    • Beiträge: 298
    Packe ich 2.0 auf den Server, so wird doch direkt eine Datenbank erstellt.
    Muss diese ja mit den Daten (Artikel, Kunden, etc.) vom alten Shop füttern.

    Ich merke schon, ich hab in letzter Zeit viel zu wenig am Shop gebastelt... -.-"

    webald

    • modified Team
    • Beiträge: 2.713
    Wenn Du den Shop in eine existierende DB (= die alte 1.06-DB, welche Du gerade zurückgespielt hast) installierst, dann wird in dieser DB ein Update ausgeführt und die alte DB damit auf die neue Struktur (2.0) gebracht.

    Die DB muss dann nicht mehr mitden alten Daten "gefüttert" werden - die sind da schon drin.

    Sandra-Media

    • Neu im Forum
    • Beiträge: 14
    • Geschlecht:
    Moinsen,

    habe gerade das Update gemacht, jedoch komme ich nicht mehr in das Backend rein.
    Ich habe den Shop vorher offline geschalten und dann das Update durchgeführt.

    Jetzt komme ich nur bis zur Login-Seite und wenn ich mich einloggen möchte, komme ich wieder zur Offline Meldung.

    Jemand eine Idee ?

    vielen Dank

    Ich hatte das gleiche Problem. Hat jemand dafür eine Erklärung? Bin jetzt erstmal auf SP4 gegangen, das klappt einwandfrei :)

    Freue mich aber auch schon auf das Responsive Template, was wirklich schön geworden ist! Großes Lob  :thx:

    TrueSlide

    • Schreiberling
    • Beiträge: 298
    Wenn Du den Shop in eine existierende DB (= die alte 1.06-DB, welche Du gerade zurückgespielt hast) installierst, dann wird in dieser DB ein Update ausgeführt und die alte DB damit auf die neue Struktur (2.0) gebracht.

    Die DB muss dann nicht mehr mitden alten Daten "gefüttert" werden - die sind da schon drin.

    Hmm, wie sage ich dir das jetzt am besten!?
    Es kommt aufs selbe bei raus.

    Alte Datenbank via MySQLDumper auf eine leere Datenbank gespielt (über die aus dem laufenden Betrieb sollte ich das wohl weniger machen). Shopinstallation über /_installer gestartet und die Kontrollkästchen abgewählt. Shop installiert.

    Ergebnis: kein anmelden möglich, Preise stehen bei "0"

    Da ich natürlich an einer Lösung interessiert bin, würde ich schon gerne weitere Lösungsansätze hören und versuchen. ;)

    hpzeller

    • Experte
    • Beiträge: 3.339
    • Geschlecht:
    Hallo TrueSlide,

    habe es auch so gemacht wie du es in Antwort #126 beschrieben hast, mit dem erst mal gleichen Ergebnis, ist ja auch nicht verwunderlich denn die Datenbankstruktur passt jetzt noch nicht zum neuen Shopsystem.

    Also habe ich den '/_installer' erneut aufgerufen und siehe da die Startseite zeigte eine zusätzliche Zeile ganz unten, siehe Bild,
    [ Für Gäste sind keine Dateianhänge sichtbar ]

    ein klick auf [Weiter] führte mich zu folgendem Bild
    [ Für Gäste sind keine Dateianhänge sichtbar ]

    da ich die Version 1.0.6.0 hatte habe ich alle Hacken bis zur Version 2.0.0.0 gesetzt und nach klick auf [Ausführen] wurde die Datenbank angepasst, jetzt kann ich mich auch im neun Shop anmelden.

    Gruss
    Hanspeter

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Hallo zusammen,

    Zitat
    Wir haben bereits mehrere Shops mit dem JTL Connector (alt und neu) am Laufen und haben keine Probleme damit.
    Gestattet mir noch einmal die Frage, ob modified 2.0 mit dem JTL-Connector hier aus dem Forum an der JTL-Wawi 1.x läuft (ist ab Post #89 untergegangen).

    Auch hatten wir das Sperrgut-Modul von NoRiddle in die 1.06 eingebaut. Soweit ich im Demoshop 2.0 sehen konnte ist in Sachen Sperrgut nichts dazu gekommen. Stellt sich also auch die Frage, ob das Sperrgut-Modul auch in die 2.0 eingebaut werden kann/muss.

    Gruß ins Forum

    TrueSlide

    • Schreiberling
    • Beiträge: 298
    Hallo hpzeller,

    ich werd nicht mehr! Dein Tipp war Gold wert bzw. war (zumindest so wie ich das bisher beurteilen kann) Gold wert.
    Einloggen ist möglich und der Shop läuft. Werde jetzt in der Nacht mal noch gucken, ob wirklich alles funktioniert, oder doch noch irgendwo Probleme auftreten.

    Wobei ich auf den ersten Blick schon eins festellen konnte. Die Umlaute zerhaut es aktuell komplett. So wird aus einem "ü" folgendes "ÃŒ" bzw. aus einem "Ü" das hier "Ã". Aus einem "ö" wird "ö"

    TrueSlide

    • Schreiberling
    • Beiträge: 298
    Ich weiß nicht ob das Absicht ist, aber so recht vorstellen kann ich es mir nicht.
    Es geht im Detail um das Zahlungsmodul "Vorkasse".

    In 1.06 Version konnte man direkt im Modul die entsprechenden Angaben tätigen. IBAN, BIC, Name der Bank und Empfänger. Kauft ein Kunde und wählt Vorkasse aus, bekommt er beim Abschluss diese Daten angezeigt.

    Bei 2.0 sieht das etwas anderes aus.
    Dort hat man nur die Option "Zahlbar an:", was nur ein Zeile ist.
    Bestellt ein Kunde via Vorkasse, wird im beim Abschluss die Bankverbindung wie folgt angezeigt.

    Bankverbindung:
    (hier wird die einze Zeile des Modus ausgegeben)

    Kontoinhaber:
    (hier wird jetzt der Block aus "Konfiguration" > "Mein Shop" ausgegeben)
    [kurz um, die Geschäftadresse die im Briefkopf landet (Anschrift, Tel., Mail etc.)]

    Wie schon erwähntlich, ich kann mir nicht vorstellen, dass das so gewollt ist. Wenn doch, dann sollte in der Konfiguration nicht nach der Geschäftsadresse etc. gefragt werden, sondern nach der Bankverbindung.
    Nur das ist wiederrum unübersichtlich. Warum nciht alles wie zuvor auch, direkt im Modul die Daten eintragen?

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.077
    • Geschlecht:
    Das war auch in der Shopversion 1.06 genau so wie in 2.00! :!:

    Was du suchst ist das Zahlungsmodul "EU-Standard Bank Transfer (eustandardtransfer)". Dort kannst du die Angaben alle einzeln angeben.

    Grüße

    Torsten

    TrueSlide

    • Schreiberling
    • Beiträge: 298
    Das hat man davon, wenn man sich die Nächte um die Ohren haut!  :datz:  :lol1:
    Du hast vollkommen recht, der Fehler lag bei mir. Beim nächsten mal erst auspennen, dann weiter machen.  :crazy:

    Jetzt habe ich das richtige Modul installiert und bekomme folgende Meldung:

    Zitat
    WARNUNG: Duplicate configuration key: MODULE_PAYMENT_EUSTANDARDTRANSFER_ALLOWED

    Ich glaub ich sollte echt ins Bett.  :n8:

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.077
    • Geschlecht:
    Deinstalliere das Modul einfach nochmal, wobei die Einträge aus der Tabelle "configuration" wieder gelöscht werden. Dann installierst du das Modul einfach erneut.

    Grüße

    Torsten

    Gamers RS

    • Fördermitglied
    • Beiträge: 26
    Hi Tomcraft. Habt gute Arbeit geleistet das kann ich nur euch schreiben. Leider hab ich erst vor kurzen auf eures System gestoßen und merkte das bei der Bestellung bei mir folgendes zusehen war.

    Es wird 2x Artikelname angezeigt. Ist es ein Bug oder normal sowas? und eine Spende sende ich euch auch zu ;) habt ihr auch verdient :)
    Marktplatz - Eine große Auswahl an neuen und hilfreichen Modulen sowie modernen Templates für die modified eCommerce Shopsoftware
    anything