Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: modified eCommerce Shopsoftware 2.0.5.1 rev 12725 veröffentlicht

    voodoopupp

    • Fördermitglied
    • Beiträge: 1.455
    • Geschlecht:
    Danke auch von meiner Seite für die unermüdliche Arbeit. :) :thumbs:

    ApK

    • Fördermitglied
    • Beiträge: 426
    Auch von mir vielen Dank für das Update. :thumbs:

    LG
    Andre

    Rocket3

    • Mitglied
    • Beiträge: 132
    • Geschlecht:
    Hallo und auch von mir vielen Dank für das Update.

    Ich habe seit dem Update das Problem, dass das "Attribute Editieren" nicht mehr funktioniert. Die Attribute sind zwar da, aber ich kann nichts anwählen oder eingeben. Das passiert beim neue Artikel zufügen, sowie beim Artikel kopieren. Habe gerade festgestellt, dass die Kästchen zum anklicken der jeweiligen Attribute nicht vorhanden sind.

    Shopssoftware v2.0.5.1 rev 12725 dated: 2020-04-22Datenbank Version: "MOD_2.0.5.1"
    Hat noch jemand das Problem bemerkt und woran liegt das ?
    Gruss Mladen

    JWi

    • Neu im Forum
    • Beiträge: 45
    @ Rocket3
    Dieses Problem kann ich nicht nachvollziehen. Sowohl bei vorhandenen als auch neuen Artikeln kann ich weiterhin die Attribute anklicken. Was sagt denn das Errorlog?

    LG
    Jenny

    CHESSBASE

    • Schreiberling
    • Beiträge: 254
    • Geschlecht:
    Vielen Dank für Eure Mühe! Ist schon eine prima Leistung, so was zu machen!

    Nun soll ich das hier noch machen:
    DB muss von Release MOD_2.0.5.0 auf MOD_2.0.5.1 aktualisiert werden.

    Aber wenn ich im Installer das Datenbankupdate ausführen will, kann ich nur das hier wählen:
    update_2.0.4.2_to_2.0.5.0.sql

    Da fehlt anscheinend diese Möglichkeit:
    update_2.0.5.0_to_2.0.5.1.sql

    Oder wird das Datenbankupdate anders durchgeführt?

    Gruß
    CHESSBASE

    oneQ

    • Viel Schreiber
    • Beiträge: 763
    Moin.
    Das kann ich mir eigentlich nicht vorstellen. Hast du mal geschaut, ob du die Datei \_installer\update\update_2.0.5.0_to_2.0.5.1.sql hochgeladen hast?

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.200
    @modifiedteam
    Kann es sein, dass die .htaccess Files aus Ticket #1769 und Ticket #1770 nicht im Updatepaket enthalten sind sondern nur in der Vollversion?

    Die Änderung aus Ticket #1768 ist in Update und Vollversion enthalten.

    Aufgefallen ist es mir beim vergleichen der Dateien des neuesten tpl_modified_responsive_1 die nicht im Ordner /templates/ sind gegen das Updatepaket. Dort ist die Änderung aus Ticket #1770 nämlich enthalten.

    Nachtrag: Die includes/extra/application_bottom/10_trustedshops.php im tpl_modified_responsive_1 ist anders als in 2.0.5.1 vermutlich um abwärtskompatibel zu sein (weil masterpayment noch drin ist) und kann bei Nutzung der Shopversion 2.0.5.1 wo masterpayment nicht mehr angeboten wird, durch die des regulären Updates ersetzt werden, oder?

    Gruß Timm

    CHESSBASE

    • Schreiberling
    • Beiträge: 254
    • Geschlecht:
    @one@: ich hatte da wohl den angegebenen Link zu früh benutzt. Darunter war anscheinend noch nicht die aktuelle version gewesen. Als ich jetzt nachgesehen habe, war sie da und nun ist auch das update_2.0.5.0_to_2.0.5.1.sql  mit dabei.
    Da werde ich das jetzt mal durchführen. Danke für den Tipp.

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.500
    • Geschlecht:
    [...]
    Ich habe seit dem Update das Problem, dass das "Attribute Editieren" nicht mehr funktioniert. Die Attribute sind zwar da, aber ich kann nichts anwählen oder eingeben. Das passiert beim neue Artikel zufügen, sowie beim Artikel kopieren. Habe gerade festgestellt, dass die Kästchen zum anklicken der jeweiligen Attribute nicht vorhanden sind.
    [...]

    Das können wir nicht nachvollziehen. Bitte lade nochmal alle Dateien des Update-Pakets per FTP-Programm in deinen Shop und teste erneut.

    [...]
    Nun soll ich das hier noch machen:
    DB muss von Release MOD_2.0.5.0 auf MOD_2.0.5.1 aktualisiert werden.

    Aber wenn ich im Installer das Datenbankupdate ausführen will, kann ich nur das hier wählen:
    update_2.0.4.2_to_2.0.5.0.sql

    Da fehlt anscheinend diese Möglichkeit:
    update_2.0.5.0_to_2.0.5.1.sql
    [...]

    Auch hier gilt, bitte alle Dateien nochmal hochladen! Dir fehlt die Datei "update_2.0.5.0_to_2.0.5.1.sql".

    [...]
    Kann es sein, dass die .htaccess Files aus Ticket #1769 und Ticket #1770 nicht im Updatepaket enthalten sind sondern nur in der Vollversion?

    Die Änderung aus Ticket #1768 ist in Update und Vollversion enthalten.

    Aufgefallen ist es mir beim vergleichen der Dateien des neuesten tpl_modified_responsive_1 die nicht im Ordner /templates/ sind gegen das Updatepaket. Dort ist die Änderung aus Ticket #1770 nämlich enthalten.
    [...]

    Käse! Du hast Recht! Da hat das macOS Programm "Find Empty Folders" seit dem Update nun auch leere Ordner gelöscht, die ".htaccess" Dateien beinhalten. Das war früher nicht so. Es wird ein entsprechendes Paket nachgeliefert!

    [...]
    Nachtrag: Die includes/extra/application_bottom/10_trustedshops.php im tpl_modified_responsive_1 ist anders als in 2.0.5.1 vermutlich um abwärtskompatibel zu sein (weil masterpayment noch drin ist) und kann bei Nutzung der Shopversion 2.0.5.1 wo masterpayment nicht mehr angeboten wird, durch die des regulären Updates ersetzt werden, oder?
    [...]

    Korrekt! Die Templates sind alle abwärtskompatibel bis Shopversion 2.0.0.0, daher sind teilweise Code-Stellen mit Fallbacks ausgestattet. Du kannst die Dateien aus dem Template "tpl_modified_responsive" verwenden oder einfach die Dateien behalten, denn die Fallbacks stören ja nun wirklich überhaupt nicht. ;-)

    @one@: ich hatte da wohl den angegebenen Link zu früh benutzt. Darunter war anscheinend noch nicht die aktuelle version gewesen. Als ich jetzt nachgesehen habe, war sie da und nun ist auch das update_2.0.5.0_to_2.0.5.1.sql  mit dabei.
    Da werde ich das jetzt mal durchführen. Danke für den Tipp.

    Kann nicht sein! Ich lade immer zuerst die Pakete hoch und veröffentliche dann den Beitrag zur neuen Shopversion! Andersrum hättest du einen toten Link erhalten.

    Allgemeiner Hinweis, da nach jedem Update immer wieder Probleme gemeldet werden, die auf FTP-Übertragungsfehler zurück zu führen sind:

    Bitte beachtet beim Upload mittels FileZilla unten den Reiter "Fehlgeschlagene Übertragungen"! Dort werden alle Dateien aufgelistet, die nicht übertragen werden konnten. Diese dann alle markieren und mit Rechtsklick wieder zur Warteschlange hinzufügen und im Reiter "Zu übertragende Dateien" dann ebenfalls per Rechtsklick die Warteschlange erneut abarbeiten! Das macht ihr so lange, bis keine fehlgeschlagenen Übertragungen mehr im Reiter "Fehlgeschlagene Übertragungen" zu finden sind!

    Grüße

    Torsten

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.200
    zu filzlila:
    und auf den binären Übertragungsmodus achten! Das kann sich bei einem update von FileZilla auch ändern. War zumindest vor einer ganzen Weile einmal bei mir der Fall.

    @Torsten
    Dateien mit einem Punkt am Anfang sind auf dem Mac eh so ein Problem. Die sieht man in Ordnern nicht, sondern kann sie nur umständlich über ein ftp Programm zb sehen und bearbeiten. Kenn ich auch wenn du von einem anderen Programm redest als den Finder. Leidiges Thema.

    Gruß Timm

    GTB

    • modified Team
    • Gravatar
    • Beiträge: 5.504
    • Geschlecht:
    [...]
    Dateien mit einem Punkt am Anfang sind auf dem Mac eh so ein Problem. Die sieht man in Ordnern nicht, sondern kann sie nur umständlich über ein ftp Programm zb sehen und bearbeiten. Kenn ich auch wenn du von einem anderen Programm redest als den Finder. Leidiges Thema.
    [...]

    Wenn du es dauerhaft haben willst, im Terminal das hier eingeben:

    defaults write com.apple.Finder AppleShowAllFiles true
    Ansonsten CMD + Shift + DOT

    Gruss Gerhard

    noRiddle (revilonetz)

    • Experte
    • Beiträge: 10.866
    • Geschlecht:
    [...]
    Kann es sein, dass die .htaccess Files aus Ticket #1769 und Ticket #1770 nicht im Updatepaket enthalten sind sondern nur in der Vollversion?
    [...]

    Ich habe in der Vollversion, entgegen deiner Aussage, zu Ticket #1770 gar keine .htaccess-Datei in
    /shoproot/includes/external/phpfastcache/src/phpFastCache/Core/Pool/IO/
    und kann daher eine Erfüllung des Tickets nicht sehen.
    Ist das so korrekt ?

    Gruß,
    noRiddle

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.500
    • Geschlecht:
    Im Ticket hatte sich Timm aka FräuleinGarn mit dem Pfad vertan. Der korrekte Pfad lautet: "/includes/external/phpfastcache/src/phpFastCache/.htaccess"

    Grüße

    Torsten

    noRiddle (revilonetz)

    • Experte
    • Beiträge: 10.866
    • Geschlecht:
    Ah, okay, dann alles sein gutt :-)
    Merci.

    Deinen "Allgemeiner Hinweis, da nach jedem Update immer wieder Probleme gemeldet werden..." solltest du vielleicht im ersten Post einfügen, dann ist die Chance größer, daß er gelesen wird.

    Gruß,
    noRiddle

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.500
    • Geschlecht:
    :good:

    Mache ich gleich noch und füge das auch zusätzlich noch nachträglich in die Installations- & Update-Anleitung im Ordner "bitte erst lesen" in die ZIP-Pakete mit ein.

    Grüße

    Torsten
               
    anything