Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: Statistik Startseite Admin soll Monat Vorjahr aber laufend anzeigen

    demoncleaner

    • Fördermitglied
    • Beiträge: 303
    Hallo Zusammen,

    ich sitze gerade vor dem Problem, dass ich versuche, dass mir die Statistik in der start.php nicht (nur) den Umsatz des Monats des Vorjahrs anzeigt, sondern den Umsatz zum selben Zeitpunkt im Vorjahr. Also z.B. wenn ich den Umsatz "Aktueller Monat" sehe und wir haben heute den 12.08.2019 dann möchte ich darunter August 2018 sehen aber eben auch nur bis zum 12.08. und nicht den gesamten August.

    Ich hab das ganze mit einer "nested" if Abfrage versucht.

    Code: PHP  [Auswählen]
       round(coalesce(sum(if(extract(year_month from o.date_purchased) = extract(year_month from current_date - interval 1 year), if(extract(day from o.date_purchased) <= extract(day from current_date), ot.value/o.currency_value, null), null)), 0), 2) this_month_last_year_current,
     

    Die liefert mir zwar was, aber das stimmt dann nicht mit dem überein, was ich in der Umsatzstatistik für den Zeitraum angezeigt bekomme. Hat jemand eine Idee was hier falsch ist? Muss ich das ganze vielleicht aufwändiger angehen und eine ganz eigene query dafür machen?

    Linkback: https://www.modified-shop.org/forum/index.php?topic=40386.0
    Haendlerbund_Leistungen_728x90_animiert

    awids

    • Experte
    • Beiträge: 2.578
    • Geschlecht:
    In der Startseiten-Statistik werden meines Wissens nur Werte nach Bestellstatus berücksichtigt, welche im Umsatzstatistik-Filter unter Konfiguration > Adminbereich Optionen ausgewählt wurden, während die "große" Statistik ohne explizite Einstellungen erstmal alles abgrast. Hast du das bedacht?

    demoncleaner

    • Fördermitglied
    • Beiträge: 303
    Oh man... den Wald vor lauter Bäumen nicht gesehen. Vielen Dank awids !!!
    Hab da so lange dran rumprobiert, dass ich es nicht gerafft hab als dann endlich halbwegs realistische Werte rauskamen, dass es nur noch eine Einstellungssache in der Konfiguration ist. Aber vielleicht hilfts ja trotzdem mal jemandem weiter. Finde das eigentlich ganz nett die "laufenden" Werte vergleichen zu können.
    0 Antworten
    1131 Aufrufe
    28. März 2015, 18:07:57 von KAT
    3 Antworten
    2360 Aufrufe
    01. März 2011, 17:11:46 von Tomcraft
    5 Antworten
    1042 Aufrufe
    28. Juni 2017, 21:02:30 von V-Pixel
    anything