Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:

Autor Thema: weiße Seite bei Ansicht eines Artikels mit Attributen nach Template-Umstieg  (Gelesen 151 mal)

Offline aponto

  • Neu im Forum
  • *
  • Beiträge: 4
    • Teile Beitrag
Hallo zusammen,

ich nutze noch die Version 2.0.3.0 und habe ein gekauftes Template installiert.

Sobald ich den ersten Artikel im Warenkorb hatte, war der Bildschirm weiß. Man konnte auf die Startseite des Shops und auch in die Kategorien, etc., aber mit jedem weiterem Artikelaufruf wurde der Bildschirm ...

Die Ursache habe ich in includes/modules/artikel_attributes.php gefunden.

Also hier meine Lösung für Zeile 130:

Code: PHP  [Auswählen]
...
        if ($products_options['price_prefix'] == "-") {
          $attr_price = $price*(-1);
        }

        $full = $products_price + $attr_price;
...

ändern in:
Code: PHP  [Auswählen]
...
        if ($products_options['price_prefix'] == "-") {
          $attr_price = $price*(-1);
        }

        $full = floatval($products_price) + $attr_price;
...

Ja, mit den Standard-Templates hatte ich keine Probleme.

Aber vielleicht kann das sonst noch jemand gebrauchen.

LG

[EDIT Tomcraft 11.01.2019: Shopversion vervollständigt, siehe: FAQ: Wichtiger Hinweis bzgl. Angabe der Shopversion!]

Linkback: https://www.modified-shop.org/forum/index.php?topic=39891.0

Offline noRiddle

  • Experte
  • *****
  • Beiträge: 9.542
  • Geschlecht: Männlich
    • Teile Beitrag
    • Webdesign Bonn - Köln
Eine Datei /includes/modules/artikel_attributes.php git es nicht in modified. Es dürfte sich also um eine Erweiterung handeln, was deine nett gemeinte Information, ohne zu wissen um welche Erweiterung es sich handelt, unverwertbar macht.

Gruß,
noRiddle


Teile per facebook Teile per linkedin Teile per twitter

topicsolved
Nach Update weiße Seite bei hinzufügen von Artikeln mit Attributen

Begonnen von m-thomas am Admin- und Shopbereich

4 Antworten
1408 Aufrufe
Letzter Beitrag 24. Juli 2015, 16:58:58
von m-thomas
topicsolved
Bug bei aktivem Sonderpreis eines Artikels nach Bearb. des Artikels, behoben

Begonnen von noRiddle am Bugs oder Funktionsfehler

7 Antworten
3353 Aufrufe
Letzter Beitrag 26. Februar 2014, 10:16:59
von foo
xx
Weiße Seite nach Template-Installation

Begonnen von DominikSchille am Installation / Update

25 Antworten
1138 Aufrufe
Letzter Beitrag 26. September 2017, 21:49:24
von Modulfux
topicsolved
Leere weiße Seite bei xtc5-Template nach Bearbeitung

Begonnen von dertobinator am Templates

8 Antworten
3524 Aufrufe
Letzter Beitrag 16. Mai 2011, 09:50:16
von Tomcraft
 


             
anything