Community > Templates

weiße Seite bei Ansicht eines Artikels mit Attributen nach Template-Umstieg

(1/1)

aponto:
Hallo zusammen,

ich nutze noch die Version 2.0.3.0 und habe ein gekauftes Template installiert.

Sobald ich den ersten Artikel im Warenkorb hatte, war der Bildschirm weiß. Man konnte auf die Startseite des Shops und auch in die Kategorien, etc., aber mit jedem weiterem Artikelaufruf wurde der Bildschirm ...

Die Ursache habe ich in includes/modules/artikel_attributes.php gefunden.

Also hier meine Lösung für Zeile 130:


--- Code: PHP   ---...
        if ($products_options['price_prefix'] == "-") {
          $attr_price = $price*(-1);
        }

        $full = $products_price + $attr_price;
...
ändern in:

--- Code: PHP   ---...
        if ($products_options['price_prefix'] == "-") {
          $attr_price = $price*(-1);
        }

        $full = floatval($products_price) + $attr_price;
...
Ja, mit den Standard-Templates hatte ich keine Probleme.

Aber vielleicht kann das sonst noch jemand gebrauchen.

LG

[EDIT Tomcraft 11.01.2019: Shopversion vervollständigt, siehe: FAQ: Wichtiger Hinweis bzgl. Angabe der Shopversion!]

Linkback: https://www.modified-shop.org/forum/index.php?topic=39891.0

noRiddle:
Eine Datei /includes/modules/artikel_attributes.php git es nicht in modified. Es dürfte sich also um eine Erweiterung handeln, was deine nett gemeinte Information, ohne zu wissen um welche Erweiterung es sich handelt, unverwertbar macht.

Gruß,
noRiddle

Navigation

[0] Themen-Index

Zur normalen Ansicht wechseln
Powered by SMFPacks SEO Pro Mod | Sitemap