Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:

Autor Thema: Schlechte Performance und Fatal error seit wenigen Tagen  (Gelesen 4666 mal)

Offline blaster31

  • Neu im Forum
  • *
  • Beiträge: 20
    • Teile Beitrag
Schlechte Performance und Fatal error seit wenigen Tagen
« am: 04. Februar 2018, 08:39:41 »
Hallo Zusammen,

Meine Kunden und ich haben festgestellt, dass seit ca. 5 Tagen beim anklicken von Produkten häufig ein weisse Seite zurück erhalten wird.

Wenn man einen Artikel sucht oder anklickt, dann gibt es Zeiten, wo die Suche nach 30 Sekunden folgende Errormeldung bring.

Code: PHP  [Auswählen]
Fatal error: Maximum execution time of 30 seconds exceeded in /home/magickar/www/magickarten.ch/shop/includes/functions/sessions.php on line 214

Diese Meldung kommt auch im Backend-Bereich, bei Bestellungen abschliessen und Datenbanksicherung. Zudem ist auch die Performance sehr langsam geworden.

Da wir seit 2 Monaten nichts an der Software geändert haben, sind wir momentan ratlos, warum von einem Tag auf den anderen solche Timeouts entstehen. Aktuell kommen praktisch keine Bestellungen mehr rein und die Kunden sind verärgert.

Wir benutzen folgende Versionen:
modified eCommerce Shopssoftware v2.0.2.2 rev 10690 dated: 2017-04-13
Datenbank Version: "MOD_2.0.2.2"

Danke für die Hilfe.

Linkback: https://www.modified-shop.org/forum/index.php?topic=38564.0

Offline Viol

  • Fördermitglied
  • *****
  • Beiträge: 1.448
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #1 am: 04. Februar 2018, 09:37:08 »
Vielleicht ein Speicherproblem auf dem Server. Ich würde mal den Anbieter kontaktieren und auch nochmal den errorlog des Servers einsehen.

Offline blaster31

  • Neu im Forum
  • *
  • Beiträge: 20
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #2 am: 04. Februar 2018, 09:46:01 »
Danke für den Tip.
Mit unserem Anbieter/Hoster habe ich schon telefoniert und das ganze angeschaut. Sie sehen nur, dass es ein Shop-Problem sein muss, den auf dem Server und der Datenbank läuft alles einwandfrei.
Welches Log muss ich da anschauen und wo liegt dieses?

Offline Viol

  • Fördermitglied
  • *****
  • Beiträge: 1.448
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #3 am: 04. Februar 2018, 09:51:18 »
Normaler Weise kann man im Loginbereich beim Hoster Logdateien herunterladen und ansehen.

Offline FräuleinGarn

  • Fördermitglied
  • *****
  • Beiträge: 3.127
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #4 am: 04. Februar 2018, 10:01:13 »
Das gleiche Problem, beim gleichen Shop wurde hier ("Shop gerät in ein Database timeout") schon von einem anderen Benutzernamen gepostet. Warum das ganze jetzt doppelt?

Offline webald

  • modified Team
  • *****
  • Beiträge: 2.712
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #5 am: 04. Februar 2018, 12:41:26 »
Echt?
https://magickarten.ch/TREUE-WIRD-BELOHNT:_:200.html
mit einer 11 MB Grafik?

Habt ihr noch mehr solcher Monsterbilder im Shop?

Offline blaster31

  • Neu im Forum
  • *
  • Beiträge: 20
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #6 am: 04. Februar 2018, 16:53:49 »
Habe soeben das Bild angepasst. Dies hat aber keine Lösung des Problems ergeben.
Bin langsam am verzweifeln...

Danke für andere Infputs oder Vorschläge-

Offline hbauer

  • Experte
  • *****
  • Beiträge: 969
    • Teile Beitrag
    • http://www.1bis3.de
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #7 am: 04. Februar 2018, 18:58:34 »
Also ich konnte das gerade an einem Produkt beobachten.

1. Aufruf: keine Probleme
2. Aufruf: weisse seite 500 Internal Server Error nach 30 sek
3. Aufruf: keine Probleme
4. Aufruf:  weisse seite 500 Internal Server Error nach 30 sek
5-10 Aufruf: keine Probleme

Also das es an der Shop Software liegt kann ich bei diesem Verhalten nicht so richtig glauben.

Hast Du Zugriff auf die access.log / error.log Deines Webservers? Das sind die beiden Dateien auf die ich erstmal schauen würde.

Hat der Hoster bestätigt das es keine (und wirklich KEINE) Änderungen auf seiner Seite in den letzten Wochen gegeben hat?

Gruß
Hagen

Offline blaster31

  • Neu im Forum
  • *
  • Beiträge: 20
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #8 am: 04. Februar 2018, 21:07:24 »
Hallo Hagen

Danke für Dein Feedback und Deine Tests.
Ich habe soeben meinem Provider geschrieben und die beiden Dateien angefordert.
Hoffe, dass diese Morgen früh bei mir eintreffen werden.
Werde diese dann Uploaden.
Melde mich wieder... Danke und Gruss

Offline christianwagner

  • Mitglied
  • ***
  • Beiträge: 117
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #9 am: 04. Februar 2018, 21:45:32 »
ich weiß nicht wo du bist aber da muss man normalerweise nichts "anfordern" darauf hast du zugriff über ftp

und ssl deaktivieren weil wenn ich manche produkte aufrufe steht das verbindung nicht sicher ist. dann kann man gleich lassen.

Offline FräuleinGarn

  • Fördermitglied
  • *****
  • Beiträge: 3.127
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #10 am: 04. Februar 2018, 23:25:44 »
SSL deaktivieren find ich nicht grad nen guten Vorschlag. Lieber drum kümmern, dass die Weiterleitungen richtig funktionieren. SSL ist mittlerweile Standard und wirkt unseriös, wenn man es nicht einsetzt.

Offline webald

  • modified Team
  • *****
  • Beiträge: 2.712
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #11 am: 05. Februar 2018, 09:43:12 »
hätte da noch was auf https://magickarten.ch/Oeffnungszeiten-Lageplan:_:4.html

resource://82af8dca-6de9-405d-bd5e-43525bdad38a/data/call_skype_logo.png

Die Bildgröße ist interessant: 1px × 0px (Skaliert zu 1px × 19px)

Offline christianwagner

  • Mitglied
  • ***
  • Beiträge: 117
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #12 am: 05. Februar 2018, 10:29:33 »
SSL deaktivieren find ich nicht grad nen guten Vorschlag. Lieber drum kümmern, dass die Weiterleitungen richtig funktionieren. SSL ist mittlerweile Standard und wirkt unseriös, wenn man es nicht einsetzt.

das bezog sich dahingehend das er es deaktivieren kann weil es sowieso nicht richtig funktioniert.

https://magickarten.ch/Oeffnungszeiten-Lageplan:_:4.html

warum dann ssl?

Offline webald

  • modified Team
  • *****
  • Beiträge: 2.712
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #13 am: 05. Februar 2018, 10:35:12 »
das ist die gleiche Seite die ich oben bemängel. Könnte an dem Bild liegen, alle anderen werden nämlcih brav über https aufgerufen.

Offline FräuleinGarn

  • Fördermitglied
  • *****
  • Beiträge: 3.127
    • Teile Beitrag
Re: Schlechte Performance und Fatal error seit wenigen Tagen
« Antwort #14 am: 05. Februar 2018, 10:47:52 »
@christianwagner
es sind doch nur die Weiterleitungen richtig einzustellen. Das kann ja nicht so schwer sein. Sieht man auch wenn man die Seite mal mit www eingibt, dass er nicht auf non-www weiterleitet.

@webald und @christianwagner
Es werden alle Produktseiten, wo das Flaggensymbol für die Sprache in den Artikeleigenschaften integriert ist als unsicher eingestuft. Nicht nur in der mit den Öffnungszeiten.

Das hatte ich im anderen Thread (siehe Antwort #4) schon geschrieben. Deshalb ist es nervig, wenn man 2 Threads zum selben Thema erstellt. Vor allem mit zwei unterschiedlichen Benutzernamen. Dann werden die Antworten gesplittet und die Helfer wissen nicht, was schon als Hilfe angeboten wurde. Und bei den zwei Benutzern weiß man auch nicht so ganz, ob es sich um die selbe Person handelt nur um das Thema zu pushen, oder ob die beiden nicht miteinander reden.


Teile per facebook Teile per linkedin Teile per twitter