Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: modified eCommerce Shopsoftware 2.0.2.0 rev 10591 veröffentlicht

    brummi49

    • Neu im Forum
    • Beiträge: 32
    • Geschlecht:
    Bei mir das gleiche.
    Ich habe mir damit geholfen, dass ich den _installer aus V 2.01 hochgezogen habe, dort die Update Datei 'update_2.0.1.0_to_2.0.2.0.sql' aus V. 2.02 ins update Verzeichnis kopiert. So konnte ich den Installer starten und das Datenbankupdate durchführen.

    Allerdings, und das war eigentlich der Grund warum ich das Update durchgeführt habe: Die Paypal Kaufabwicklung funktioniert leider immer noch nicht. Beim Bezahlvorgang mit Paypal Classic erfolgt immer noch der Abbruch

    GNLA

    • Neu im Forum
    • Beiträge: 12
    • Geschlecht:
    @ GTB

    mein Browser akzeptiert cokies, habe es in Firefox sowie in Edge probiert ohne Erfolg.
    Immer wieder die Anmeldeendlosschleife

    Das mit Installer aus 2.0.1  funkt bei mir auch nicht.

    Ich frage nochmal, kann ich die Datenbank nicht manuell per phpMyAdmin anpassen?

    Danke im Voraus

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.427
    Dann probier doch mal meinen Tipp von heut morgen bzgl ssl weiterletung.

    Hat GTB bei mir geändert und dann ging es. Hab es gerade nochmal nachgestellt. Funktioniert nur wenn auskommentiert siehe hier drunter. Wenn die # weg sind bleib ich auch in der Endlosschleife hängen.

    .htaccess
    ##-- redirect to https www-domain, when www is missing and no subdomain given and not using an ssl-proxy
      #RewriteCond %{HTTP_HOST}                 !^www\. [NC]
      #RewriteCond %{HTTP_HOST}                 !\.(.*)\. [NC]
      #RewriteCond %{HTTP_HOST}                 !^localhost [NC]
      #RewriteRule ^ https://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
      #RewriteCond %{HTTPS} off
      #RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

    mr.august

    • Neu im Forum
    • Beiträge: 27
    Bei mir das gleiche.
    Ich habe mir damit geholfen, dass ich den _installer aus V 2.01 hochgezogen habe, dort die Update Datei 'update_2.0.1.0_to_2.0.2.0.sql' aus V. 2.02 ins update Verzeichnis kopiert. So konnte ich den Installer starten und das Datenbankupdate durchführen.

    Allerdings, und das war eigentlich der Grund warum ich das Update durchgeführt habe: Die Paypal Kaufabwicklung funktioniert leider immer noch nicht. Beim Bezahlvorgang mit Paypal Classic erfolgt immer noch der Abbruch

    Vielen Dank für den Tipp mit dem alten Installer, hat funktioniert !

    Jetzt hänge ich wie du aber auch beim selbem Problem mit PayPal ... Immer wieder Abbruch :(

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.427
    Hab jetzt nochmal komplett neu installiert. Mit Fix kann man installieren. Dort funktioniert nun der Admin-Login. Wenn man dann aber eine alte DB wiederherstellt und diese dann updaten will, landet man wieder in einer Endlosschleife des Logins. Das mit ändern der .htaccess hilft dann auch nicht. das mit dem workaround mit hilfe des alten installers hab ich gelesen. Sollte aber eigentlich auch so funktionieren.

    Noch was. Nach einen frischen Installation sollte man bei Zahlungsmöglichkeiten die Logos für Paypalplus sehen und auswählen können im standard tpl_modified template,oder? Das klappt bei mir auch nicht. Noch jemand das Problem? Mit meinem eigen Template sieht man sie aber.

    Giorgio

    • Neu im Forum
    • Beiträge: 19
    Guten Tag zusammen,

    ich möchte gerne die beiden letzten Updates installieren und habe folgendes Problem:

    Meine derzeitig installierte Shop-Version ist v2.0.0.0 rev 9678 dated: 2016-04-02, die stabil läuft.

    Um auf den neuesten Stand zu kommen, müsste ich die beiden Updates
    2.0.1.0 rev 10403 und danach 2.0.2.0 rev 10591 installieren.

    Die Updateanleitung sagt u. a.

    Zitat
    Inhalt des Ordners "shoproot" mit FTP-Client auf den Server in den Ordner des zu aktualisierenden Shops übertragen.
    Das kann ich natürlich machen, und dabei habe ich das mulmige Gefühl, dass von mir modifizierte Dateien überschrieben werden und nun nicht mehr zur Verfügung stehen.

    Der Hinweis zu Update von 2.0.0.0 rev 9678

    Zitat
    1. Die configure.php Datei muss aktualisiert werden. Siehe hierzu: http://www.modified-shop.org/forum/index.php?topic=5203.0
    bringt mich nicht weiter, weil dort uralte Einträge sind, bei denen ich keinen Bezug zu den beiden aktuellen Versionen erkennen kann.

    und

    4.
    Zitat
    Template-Anpassungen durchführen: https://www.modified-shop.org/wiki/Tutorial:_Template_eines_xt:Commerce_Shops_in_der_modified_eCommerce_Shopsoftware_weiter_verwenden#.C3.84nderungen_ab_Version_2.0.0.0

    wirft die Frage auf:"Muss ich alle dort aufgeführten Änderungen (Änderungen ab Version 2.0.0.0) von Hand durchführen?"

    Momentan neige ich eher zu dem Grundsatz:
    Zitat
    Never change a running system
    aber vielleicht kann mich ja jemand "beruhigen".

    Beste Grüße
    Giorgio

    noRiddle (revilonetz)

    • Experte
    • Beiträge: 11.107
    • Geschlecht:
    Zuerst auch von mir ein großes Danke an das modified-Team für das neue Paket.
    Ebenfalls geht ein Danke an alle die dazu beitragen durch Tests und Bug-Meldungen sowie Fix-Vorschläge (wobei ich mir da auch selbst danken müsste ;-)).

    Dann eine Frage:
    Hat es einen bestimmten Hintergrund, daß Javascript immer noch mittels HTML-Kommentaren
    Code: XML  [Auswählen]
    <script>
    <!--

    -->
    </script>
    eingefasst wird (z.B. in /includes/classes/payment.php oder auch /includes/form_check-js.php)

    anstatt mit
    Code: XML  [Auswählen]
    <script>
    /* <![CDATA[ */

    /* ]]> */
    </script>

    oder
    Code: XML  [Auswählen]
    <script>
    //<![CDATA[

    //]]>
    </script>

    Das stört imho den ansonsten cleanen Quellcode und ist nicht w3c-konform.

    In HTML5 ist das Einfassen zwar ohnehin nicht nötig, könnte jedoch beibelassen werden, falls jemand seinen Shop auf XHTML betreibt, dann jedoch w3c-konform.

    Gruß,
    noRiddle

    web28

    • modified Team
    • Beiträge: 9.404
    Hallo

    Nach dem Fix einspielen kann ich mich zwar einloggen und komme auf die erste Seite des Installers.
    Beim Klick auf Weiter Button erscheint erneut das Anmeldeformular usw, usw irgend wie ist es ne Endlosschleife. Hat einer ne Idee? An Admin Anmeldedaten liegt es nicht, die sind ja korrekt.

    Das kann ich nachstellen. Eine Lösung ist in Arbeit, siehe Ticket #1120.

    Gruss Web28

    FräuleinGarn

    • Fördermitglied
    • Beiträge: 4.427
    Zitat
    Das kann ich nachstellen. Eine Lösung ist in Arbeit, siehe Ticket #1120.

    Gruss Web28
      :thx: :pro:

    Was ist mit den paypalplus logos? Ist das auch nachstellbar? Sollte doch funktionieren nach neuinstallation und ungeändertem tpl_modified template.

    web28

    • modified Team
    • Beiträge: 9.404
    Hier das neue Fixpaket für den Installer (nur wichtig beim Update)

    Damit alles funktioniert muss die Datenbank der Vorversion erneut importiert werden und danach den Installer aufrufen.

    Bitte kontrolliert nach dem Import ob die Sonderzeichen korrekt in die DB geschrieben wurden.

    Gruss Web28

    lithoverlag

    • Fördermitglied
    • Beiträge: 593
    • Geschlecht:
    Hilft das fix auch wenn nach dem einloggen ich auf

    _installer/update.php?lg=german

    weiterkomme, aber dann mit einem weißen leeren Bildschirm ende?

    Andreas Kroll

    • Fördermitglied
    • Beiträge: 212
    • Geschlecht:
    Leider nicht. Da harkt es bei mir auch .....

    lithoverlag

    • Fördermitglied
    • Beiträge: 593
    • Geschlecht:
    geteiltes Leid ist doppelt sch...
    nun ja was mich ärgert, ist, dass ich das heute morgen schon für einen anderen Kunden gemacht hatte und da funztes es ohne Probleme.
    Der zweite Kunde ist bei alfahosting (könnte es daran liegen)

    Andreas Kroll

    • Fördermitglied
    • Beiträge: 212
    • Geschlecht:
    Ich bin bei allincl.com.

    lithoverlag

    • Fördermitglied
    • Beiträge: 593
    • Geschlecht:
    Hast du die ganze Seite per SSL gesichert?