Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: MODUL: PayPal PLUS Zahlungsmodul für modified eCommerce Shopsoftware

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    Hallo Torsten,

    wenn es an der PHP-Version liegt, ist das Problem wohl eher anders gelagert.  :mhhh:

    Denn es handelt sich um einen Server von All-Inkl.com, auf dem sogar schon PHP7 installiert ist. Wegen der Inkompatibiliät mit dem Shop habe ich PHP5.6 als CGI/FPM-Modul über die .htaccess eingeschaltet. Könnte das ein Grund sein?

    Liebe Grüße

    Alex

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.843
    • Geschlecht:
    Kannst du bitte mal schauen, dass unter "Hilfsprogramme" -> "Server Info" auch wirklich PHP 5.6 angezeigt wird?

    Ich habe das Modul für Shopversion 2.0.0.0 rev 9678 gerade nochmal in einem frisch installierten Shop getestet und kann keinen Fehler feststellen.

    Grüße

    Torsten

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    Da wird alles als PHP5.6 angezeigt:

    [ Für Gäste sind keine Dateianhänge sichtbar ]

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.843
    • Geschlecht:
    Kannst du die Domain mal bitte über den KAS auf PHP 5.6 stellen anstatt über .htaccess?

    Grüße

    Torsten

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    Da muss ich erst den Kunden fragen, ob er mir Einlass gewährt. Mail ist raus, aber ich weiß nicht, wie schnell er reagiert.

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    So, nun läuft es als PHP5.6-Modul (nicht CGI/FPM) und der Fehler bleibt - selbst nach einer kompletten Modul-Neuinstallation.  :nixweiss:

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.843
    • Geschlecht:
    Kannst du den Shop mal testweise auf einen anderen Server rüber holen und dort testen?

    Grüße

    Torsten

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    Nur lokal auf XAMPP. Lädt gerade herunter.

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.843
    • Geschlecht:
    Da wirst du Probleme haben wegen dem notwendigen SSL-Zertifikat und TLS v1.2, denke ich.

    Grüße

    Torsten

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    Ich wollte ja keine Transaktion testen, sondern nur wissen, ob der Fehler auch lokal allein beim Aufruf der checkout_confirmation.php auftritt. Die Antwort ist bedauerlicherweise ja.  :mhhh:

    awids@online.de

    • Experte
    • Beiträge: 3.116
    • Geschlecht:
    Problem gelöst. Ich habe unter

    Code: XML  [Auswählen]
    \includes\external\paypal\lib\PayPal\Api

    eine Transaction.php gefunden, welche komplett leer war. Aus einem Backup eines anderen Shops habe ich die Datei dann überschrieben und es funktioniert wieder.

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.843
    • Geschlecht:
    Ah super, danke für die Rückmeldung! :thx:

    Grüße

    Torsten

    Viol

    • Fördermitglied
    • Beiträge: 1.714
    Die Module in Beitrag 1 wurden erneut aktualisiert. Wer bereits eine ältere Version des Moduls installiert hatte, der lädt bitte einfach den Inhalt des Ordners "NEW_FILES" erneut in seinen Shop.

    Zusätzlich sind noch folgende Dateien aus dem Ordner "CHANGED_FILES" zu bearbeiten:

    Für Shopversion 1.05, 1.06 rev 4642, 1.06 rev 4642 SP1, 1.06 rev 4642 SP2, 1.06 rev 4642 SP3
    • /includes/classes/order.php

    Für Shopversionen 1.06 rev 4642 SP4
    • /includes/classes/order.php

    Für Shopversion 2.0.0.0 rev 9678
    • /includes/classes/order.php

    Da hier davon ausgegangen wird, dass der Shopbetreiber an diesen Dateien keine Änderungen vorgenommen hat, können die Dateien aus dem Ordner "CHANGED_FILES" für Shopversion 2.0.0.0 rev 9678 einfach in den Shop kopiert werden.

    Grüße

    Torsten

    Nur als guten Rat ;-) : wer Amazon-Payments installiert hat, sollte die Datei nicht überschreiben...

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.843
    • Geschlecht:
    Die Module in Beitrag 1 wurden erneut aktualisiert. Wer bereits eine ältere Version des Moduls installiert hatte, der lädt bitte einfach den Inhalt des Ordners "NEW_FILES" erneut in seinen Shop.

    Zusätzlich sind noch folgende Dateien aus dem Ordner "CHANGED_FILES" zu bearbeiten:

    Für Shopversionen 1.06 rev 4642 SP4 & 2.0.0.0 rev 9678
    • /includes/external/paypal/classes/PayPalPayment.php

    Da hier davon ausgegangen wird, dass der Shopbetreiber an diesen Dateien keine Änderungen vorgenommen hat, können die Dateien aus dem Ordner "CHANGED_FILES" für die genannten Shopversionen einfach in den Shop kopiert werden.

    Das Update behebt einen Fehler mit der Steuerberechnung.

    Grüße

    Torsten

    Viol

    • Fördermitglied
    • Beiträge: 1.714
    Nachtrag: Wer das responsive Template hat, darf auch die Template Dateien nicht einfach überschreiben...
               
    anything