Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:

Autor Thema: Aktive Artikel werden in der Unterkategorie nicht angezeigt  (Gelesen 2004 mal)

Offline Nessy

  • Fördermitglied
  • *****
  • Beiträge: 111
  • Geschlecht: Weiblich
    • Teile Beitrag
    • maxundmia.de
Hallo und einen schönen Mittwoch erst mal!

Irgendwie ist bei mir der Wurm drin..

Ich übertrage per JTL die Artikel in den Shop.

Artikel ist im Backend aktiv, die Verlinkungen zu den Kategorien stehen dort auch.
Aber.. sie werden nicht in diesen Kategorien angezeigt.

Ich kann dies nur beheben, in dem ich im Backend auf jeden neuen Artikel auf "Bearbeiten" klicken und dann auf "speichern.
Dann wird der Artikel in den Kategorien angezeigt.

Wo ist hier der Wurm drin?
JTL, modified, Datenbank?
 Gruß Nessy


Linkback: https://www.modified-shop.org/forum/index.php?topic=30759.0

Offline ShopNix

  • Viel Schreiber
  • *****
  • Beiträge: 1.205
    • Teile Beitrag
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #1 am: 30. Juli 2014, 16:58:22 »
Möglicherweise in der Schnittstelle.

Hast Du mal die Inhalte der DB für einen fehlerhaften mit einem guten Artikel Artikel verglichen?

Minimal sind die Tabellen products, products_description und products_to_categories betroffen.

Offline Wulf

  • Neu im Forum
  • *
  • Beiträge: 32
  • Geschlecht: Männlich
    • Teile Beitrag
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #2 am: 30. Juli 2014, 16:58:37 »
Hi

Hatte vor kurzem ein ähnliches Problem.

Versuch mal dein Cache im admin zu leeren...

LG

Offline Nessy

  • Fördermitglied
  • *****
  • Beiträge: 111
  • Geschlecht: Weiblich
    • Teile Beitrag
    • maxundmia.de
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #3 am: 30. Juli 2014, 17:08:27 »
Den Cache löschen mache ich fast täglich.

Das Problem besteht auch schon seit Wochen...

Mir (als Laie) ist bei der Datenbank im Vergleich zweier Artikel nichts aufgefallen.

Könnte vielleicht die Lösung sein, daß ich mir den Connector noch mal neu installiere?

Offline ShopNix

  • Viel Schreiber
  • *****
  • Beiträge: 1.205
    • Teile Beitrag
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #4 am: 30. Juli 2014, 17:33:47 »
Auf Deinem Bildchen sehe ich auch nichts.

Vielleicht ein bisschen präziser:

Gehe auf products, ändere das SQL so ab, wobei Du natürlich Deine Artikelnummern einsetzt:

Code: SQL  [Auswählen]
SELECT * FROM `products` WHERE products_model = 'A0802' OR products_model = 'A0801'

Dann hast Du zwei Artikel direkt untereinander stehen und kannst vergleichen.

Anschließend gehst Du auf products_description, hier erweiterst Du das SQL um die products_id, die Du dem Ergebnis aus dem ersten Select entnimmst:

Code: SQL  [Auswählen]
SELECT * FROM `products_description` WHERE products_id = 4 OR products_id = 5

Hätte ich fast vergessen: Wenn das Löschen des Cache das Problem erledigt, kannst Du Dir das SQL schenken.

Offline Modulfux

  • Experte
  • *****
  • Beiträge: 3.590
  • Geschlecht: Männlich
    • Teile Beitrag
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #5 am: 30. Juli 2014, 17:43:42 »
Da ich jetzt das Problem genauer verstanden habe, vermute ich, dass der Timestamp in der Tabelle products entweder bei date_added oder last_modified nicht gesetzt wird.

Nessy, schiebe mal bitte einen Artikel einzeln mit der WaWi ins System und dann machst du mal ein
Code: SQL  [Auswählen]
SELECT * FROM products WHERE products_id = ???;
und postest die Ausgabe hier.

Die ??? ersetzt du natürlich mit der Produkts-Id des eben erstellten Artikels.

Gruß
Ronny

Offline Nessy

  • Fördermitglied
  • *****
  • Beiträge: 111
  • Geschlecht: Weiblich
    • Teile Beitrag
    • maxundmia.de
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #6 am: 30. Juli 2014, 17:54:09 »
Hallo Ronny hier die Screenshots der Ausgabe

Offline ShopNix

  • Viel Schreiber
  • *****
  • Beiträge: 1.205
    • Teile Beitrag
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #7 am: 30. Juli 2014, 18:08:05 »
Warum machst Du Dir das Leben so schwer?

Es ist doch viel einfacher, einen "guten" mit einem "schlechten" Artikel direkt zu vergleichen, und den kleinen SQL-Schnippel einzutupfen ist doch nun wirklich nicht schwer.

Offline Bonsai

  • Viel Schreiber
  • *****
  • Beiträge: 4.147
  • Geschlecht: Männlich
    • Teile Beitrag
    • J.K.Fischer Shop
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #8 am: 31. Juli 2014, 15:59:23 »
Die group_permission Felder sind auf 0

Bei mir steht da 1 drin.

Ich kenne die JTL Schnittstelle nicht, aber falls die Kundengruppen unterstützt, musst du den jeweiligen Gruppen erlauben die Artikel zu sehen.

Offline Nessy

  • Fördermitglied
  • *****
  • Beiträge: 111
  • Geschlecht: Weiblich
    • Teile Beitrag
    • maxundmia.de
Re: Aktive Artikel werden in der Unterkategorie nicht angezeigt
« Antwort #9 am: 31. Juli 2014, 17:26:04 »
@shopnix

Es liegt nicht an der Datenbank.

Anscheinend hängt das Problem mit dem Alkim Produktfilter zusammen.

Melde mich, wenn wir mehr wissen.
Gruß und schönen Abend!

Werbung / Banner buchen

Teile per facebook Teile per linkedin Teile per twitter