Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: modified eCommerce Shopsoftware 1.06 rev 4642 SP1 veröffentlicht

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Wir haben uns kurzfristig dazu entschieden die Shopversion 1.06 rev 4642 nochmal mit einem Service-Paket (SP1) zu versehen.

    Enthalten sind die Umsetzung der EU-Verbraucherrichtlinie, sowie das SEPA-Lastschrift-Paket, siehe dazu auch: Anleitung zur Umsetzung der EU-Verbraucherrichtlinie & SEPA-Lastschriftverfahren

    Achtung: Seit 1.05 SP1b setzen wir mindestens PHP 5 voraus! :!:

    Helft uns, diese Meldung zu verbreiten, und teilt es auf Facebook, twittert, blogt oder emailt es euren Freunden und Bekannten.

    Wir wünschen euch viel Spaß mit der neuen Version und freuen uns auf euer Feedback.

    Bitte beachtet die Textdateien im Ordner "bitte_erst_lesen"!

    Der Download ist wie gewohnt auf der Download-Seite zu finden.

    Wenn euch die Shopsoftware gefällt, dann freuen wir uns über ein wenig finanzielle Unterstützung.

    Wir wünschen euch viel Erfolg bei der Umsetzung eurer Shop-Projekte mit der modified eCommerce Shopsoftware.

    Das modified eCommerce Shopsoftware Team

    Linkback: https://www.modified-shop.org/forum/index.php?topic=30386.0

    S_teffi

    • Frisch an Board
    • Beiträge: 53
    Hallo liebes modified-Team,

    die Anleitung zum Update ist ja in der "_Updateanleitung auf neuere Version.txt" in Schritt 1 bis 7 erklärt. Sollen die mitgelieferten Dateien vor diesen Schritten einfach nur per FTP mit den existierenden Dateien ersetzt werden?

    Sorry für die eher unschlaue Frage :-( hab im Forum und der Doku nichts genaueres dazu gefunden und bevor ich mir irgendetwas zerhaue, wollte ich lieber nachfragen.

    Liebe Grüße, Steffi

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Wenn du eine ältere Shopversion einsetzt, dann schau am besten mal hier: ANLEITUNG: modified eCommerce Shopsoftware v1.0x auf v1.0y aktualisieren

    Grüße

    Torsten

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Hallo Torsten,

    zunächst vielen Dank für das Zurverfügungstellen eines umfassenden Updates hinsichtlich der Juni-Thematik.

    Ich habe die Anleitung für das Update auf 1.06 rev.4642 SP1 durchgearbeitet und
    scheitere beim Punkt

    Zitat
    3. Im Browser das Update starten mit:
    http://<meinshop>/update.php

    Ich habe nämlich keine Datei update.php in meiner Installation.

    shoproot befindet sich in einem Unterverzeichnis zur Domain.
    (www.meinedomain.net/eshop)
    Aber eben dort finde ich keine ´update.php´.

    Soll diese im Standard dort liegen oder fehlt diese Datei im Installationspaket SP1?

    Beste Grüße
    Rosco
    (ein modified-Newbie)

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Der Punkt in der Anleitung ist doch für das "Update von 1.05/1.05SP1d". Wenn du diese Shopversion aktualisieren möchtest, dann musst du der Reihe nach die Updates einspielen.

    Grüße

    Torsten

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Ups, dann habe ich mich aber mächtig durch den Wortlaut:
    "Nun zum eigentlichen Update"
    verunsichern lassen.

    Ja, er steht unter der Überschrift: "Update von 1.05./1.05SP1d.
    Aber die nachfolgende Chronologie hatte ich auf alle Updates bezogen.

    Entschuldigung, da fehlen mir offensichtlich die Zusammenhänge und ich habe es nicht richtig gedeutet.
    Im ersten Abschnitt der Update-Hinweise (also für meine Version) hätte ich einen Hinweis auf das Ersetzen der vorhandenen Inhalte mit denen aus dem Servicepack erwartet.
    Oder liege ich damit wieder falsch?

    Beste Grüße
    Rosco

    moscbabe

    • Frisch an Board
    • Beiträge: 86
    Thema: "modified eCommerce Shopsoftware 1.06 rev 4642 SP1b veröffentlicht"

    Ich kann nur SP1 finden

    Tippfehler?

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Ok, nach der Anleitung für Updates habe ich nun die Verzeichnisse und Dateien ersetzt.
    Beim Importieren der Datenbank-Datei ergab sich jedoch ein Fehler:

    Zitat
    INSERT INTO configuration (configuration_id, configuration_key, configuration_value, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'STORE_OWNER', 'modified eCommerce Shopsoftware', 1, 2, NULL, NOW(), NULL, NULL);

    MySQL meldet:
    Zitat
    #1062 - Duplicate entry '0' for key 'PRIMARY'

    Leider kann ich dies nicht "übersetzen" und bin für jeden Hinweis dankbar...

    Wemheuer

    • Neu im Forum
    • Beiträge: 18
    Ist denn die Umsetzung der EU-Verbraucherrichtlinie, sowie das SEPA-Lastschrift-Paket die einzigen beiden Änderungen in SP1?
    Im Changelog steht dazu leider nichts weiter.

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Oh, neeee!!!
    Jetzt habe ich die Datenbank mit der Datei aus dem Servicepack aktualisiert und nun habe ich nach Aufruf des Shops nur noch ein weißes Fenster.
    Ich habe zwar vorher im Shop die Datenbank gesichert, aber da komme ich ja nun nicht ran...

    Jetzt bin ich aufgeschmissen und hoffe sehr auf freundliche Hilfe...

    Gruß ins Forum
    Rosco

    voodoopupp

    • Fördermitglied
    • Beiträge: 1.469
    • Geschlecht:
    ftp-zugriff?

    Dann einfach mal in den Ordner /export eine Datei anlegen:
    _error_reporting.all

    notfalls auch gleich mal noch
    _error_reporting.shop

    Dann sollte zumindest ein Fehler anstatt ner weißen Seite auftauchen.
    Bitte danach auch wieder rausnehmen, ansonsten bekommen die Kunden immer alle Errors vor den Latz geknallt ;)

    Grüße
    Dominik

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Ok, nach der Anleitung für Updates habe ich nun die Verzeichnisse und Dateien ersetzt.
    Beim Importieren der Datenbank-Datei ergab sich jedoch ein Fehler:

    Zitat
    INSERT INTO configuration (configuration_id, configuration_key, configuration_value, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES ('', 'STORE_OWNER', 'modified eCommerce Shopsoftware', 1, 2, NULL, NOW(), NULL, NULL);

    MySQL meldet:
    Zitat
    #1062 - Duplicate entry '0' for key 'PRIMARY'

    Leider kann ich dies nicht "übersetzen" und bin für jeden Hinweis dankbar...

    Wie kommst du denn auf die Idee die "modified.sql" Datei zu importieren? :-?
    Zum Glück hast du ein Backup deiner Datenbank erstellt. Das findest du im Ordner "/admin/backups/" und kannst es per phpMyAdmin wieder in deine Shop-Datenbank einspielen. :!:

    Ist denn die Umsetzung der EU-Verbraucherrichtlinie, sowie das SEPA-Lastschrift-Paket die einzigen beiden Änderungen in SP1?
    Im Changelog steht dazu leider nichts weiter.

    Ja, das sind die einzigen beiden Änderungen. Ich aktualisiere die "Changelog.txt" im Download-Paket gleich nochmal.

    Grüße

    Torsten

    S_teffi

    • Frisch an Board
    • Beiträge: 53
    Hallo Torsten,

    zum Glück habe ich es noch nicht gemacht, aber die "modified.sql" hätte ich auch importiert, weil es in der Anleitung (Tutorial: modified eCommerce Shopsoftware v1.0x auf v1.0y aktualisieren) so stand, die du mir geschickt hattest.

    Möchte auch nur von 1.06 rev 4642 auf 1.06 rev 4642 SP1 "updaten" und da in der "_Updateanleitung auf neuere Version.txt" nicht genau stand, was man denn nun genau mit den mitgelieferten Dateien der .zip machen soll, hatte ich hier lieber nochmal nachgefragt.

    Also doch nur Dateien aus dem Ordner admin, includes, lang und templates, sowie die checkout_shipping.php und die send_order.php hochladen/ersetzen?

    Liebe Grüße, Steffi

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    [...]
    zum Glück habe ich es noch nicht gemacht, aber die "modified.sql" hätte ich auch importiert, weil es in der Anleitung (Tutorial: modified eCommerce Shopsoftware v1.0x auf v1.0y aktualisieren) so stand, die du mir geschickt hattest.
    [...]

    Nein, steht dort nicht in der Anleitung. Das hast du vermutlich falsch verstanden.

    [...]
    Also doch nur Dateien aus dem Ordner admin, includes, lang und templates, sowie die checkout_shipping.php und die send_order.php hochladen/ersetzen?
    [...]

    Ganz genau! Und sofern du ein eigenes Template einsetzt noch die Änderungen für das Template durchführen.

    Grüße

    Torsten

    S_teffi

    • Frisch an Board
    • Beiträge: 53
    ah oki gut danke, mich hatte nur der Ordner "_installer" mit der Datei "modified.sql" irritiert und da hatte ich den dann mit "xtc_installer" und "update_1.0x_to_1.0y.sql" aus der Anleitung gleichgesetzt.

    Also den Ordner "_installer" komplett ignorieren oder auch hochladen?

    Liebe Grüße, Steffi

    Wemheuer

    • Neu im Forum
    • Beiträge: 18
    Ja, das sind die einzigen beiden Änderungen. Ich aktualisiere die "Changelog.txt" im Download-Paket gleich nochmal.

    Grüße

    Torsten

    Super, Danke! :thumbs:

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Ich danke dir für den Hinweis! :thx:

    Pakete sind aktualisiert. :!:

    Grüße

    Torsten

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    ah oki gut danke, mich hatte nur der Ordner "_installer" mit der Datei "modified.sql" irritiert und da hatte ich den dann mit "xtc_installer" und "update_1.0x_to_1.0y.sql" aus der Anleitung gleichgesetzt.

    Also den Ordner "_installer" komplett ignorieren oder auch hochladen?
    [...]

    Argh... der Ordner sollte gar nicht mit ins Update-Paket! Danke für den Hinweis! :!:
    Bitte den Ordner "/_installer/" ignorieren. Ich aktualisiere das Paket gleich nochmal.

    Grüße

    Torsten

    AGI

    • modified Team
    • Beiträge: 254
    • Geschlecht:
    Danke für das Update,

    diese Datenbankänderungen aus der SEPA-Erweiterung sollten aber dennoch erwähnt werden:

    Code: SQL  [Auswählen]
    ALTER TABLE banktransfer ADD banktransfer_iban VARCHAR(34) DEFAULT NULL AFTER banktransfer_blz;
    ALTER TABLE banktransfer ADD banktransfer_bic VARCHAR(11) DEFAULT NULL AFTER banktransfer_iban;
    ALTER TABLE banktransfer ADD banktransfer_owner_email VARCHAR(96) DEFAULT NULL;

    Viele Grüße

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Ach Käse... ich war der Meinung, dass die Änderungen kommen, wenn man das Modul "Lastschriftverfahren (banktransfer)" einmal deinstalliert und wieder neu installiert... Fehlanzeige...

    Ich werde die Pakete nochmals aktualisieren, danke für den Hinweis! :thx:

    Grüße

    Torsten

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Jo, wegen des Ordners ´_Installer´ bin ich eben auch auf das Update der Datenbank reingefallen.
    Ich meine nämlich, ich hatte im dem separaten Thread zum SEPA-Lastschriften Modul gelesen, dass eine Erweiterung der Datenbank notwendig ist.
    Daher dachte ich, dieses wäre in der ´modified.sql´ enthalten.

    Jetzt muss ich sehen, wie ich die Kuh vom Eis bekomme.
    Gestattet mir daher eine Nachfrage zuviel, bevor ich jetzt noch mehr Murks baue.

    Ich hatte die Ordner und die Dateien aus dem SP1 Paket vom 15.06.2014 in das shoproot geladen und
    die ´modified.sql`importiert.
    Danach der "White Screen" beim Shopaufruf.

    1 Sehe ich das richtig, dass ich zunächst das SQL-Datenbank Update wieder in die Datenbank importieren muss?

    2. Die Datei liegt als GZ-Datei vor, muss diese vorher noch entpackt werden?

    3. Welche Änderungen muss ich nun noch gegenüber dem SP1 von gestern vornehmen?

    Beste Grüße
    Rosco

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Ok, ein Herz gefasst und das Datenbank-Update zurückgespielt.
    Jupp, nun klappt es wieder mit dem Shop Zugang.

    Dank an voodoopupp und Tomcraft für die erste Hilfestellung!

    Die Verzeichnisse und Dateien aus dem SP1-Update sind auch hochgeladen und die Content-Dateien angepasst.
    So weit so gut...

    Nur sind nun nach dem Import der Datenbankdatei alle Umlaute einem ?-Fragezeichen gewichen.
    Habe ich einen Fehler beim Import der Datenbank gemacht?

    Als Zeichencodierung beim Import über PHPMyAdmin war UTF-8 voreingestellt. Hat´s mir deswegen alle Umlaute und Sonderzeichen zerrissen?
    Ich habe den Shop im Moment im Wartungsmodus. Somit könnte ich das Backup erneut einspielen. Aber welcher Zeichensatz ist aus der mannigfaltigen Auswahl der richtige?  :-?
    Da ich ja nun wieder in die Shop-Administration komme, ist das Wiederherstellen aus dem Datenbankmanager im Backend sinnvoller, sprich erfolgsversprechender?

    Gruß ins Forum
    Rosco

    Dato

    • Mitglied
    • Beiträge: 214
    Hallo,
    und Danke fpr die Neue version.

    Eine Frage habe ich und zwar, welche Dateien wurden genau bearbeitet weil ich das TEMPLATE: Bootstrap - freies responsive Template verwende und ich nicht weiss ob sich die Dateien sich eventuell beissen.

    Daher wäre es hilfreich zu wissen welche Dateien ändert wurden.

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Welche Dateien geändert wurden steht doch in der Update-Anleitung drin:

    Zitat
    [...]
    7. Für Fremd-Templates sind noch die folgenden Änderungen unter "1.2.4 Template Dateien ändern" auf der folgenden Seite durchzuführen: https://www.modified-shop.org/wiki/Tutorial:_Umsetzung_der_EU-Verbraucherrichtlinie_vom_13.06.2014#Template_Dateien_.C3.A4ndern
    [...]

    [...]
    Nur sind nun nach dem Import der Datenbankdatei alle Umlaute einem ?-Fragezeichen gewichen.
    Habe ich einen Fehler beim Import der Datenbank gemacht?

    Als Zeichencodierung beim Import über PHPMyAdmin war UTF-8 voreingestellt. Hat´s mir deswegen alle Umlaute und Sonderzeichen zerrissen?
    [...]

    Spiele das Backup nochmal ein und wähle den Zeichensatz "latin 1" oder "windows 1257" aus, je nachdem welche Version von phpMyAdmin dir vorliegt.

    Grüße

    Torsten

    ShopNix

    • Viel Schreiber
    • Beiträge: 1.208
    Aufpassen: Windows 1257 ist irgendwas östliches. Für unsereins gilt 1252!

    vsell

    • BVB Fan
    • Viel Schreiber
    • Beiträge: 2.802
    • Geschlecht:
    1250 (Central Europe)
    1251 (Cyrillic)
    1252 (Latin I)
    1253 (Greek)
    1254 (Turkish)
    1255 (Hebrew)
    1256 (Arabic)
    1257 (Baltic) wird benutzt um Estnische (auch möglich mit Windows-1252), Lettische und Litauische Zeichen zu kodieren
    1258 (Vietnam)
    874 (Thai)

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Danke für die Korrektur. :thx:

    Dann hatte ich das nicht mehr ganz richtig im Kopf. :oops:

    Grüße

    Torsten

    Dato

    • Mitglied
    • Beiträge: 214
    Welche Dateien geändert wurden steht doch in der Update-Anleitung drin:

    Zitat
    [...]
    7. Für Fremd-Templates sind noch die folgenden Änderungen unter "1.2.4 Template Dateien ändern" auf der folgenden Seite durchzuführen: https://www.modified-shop.org/wiki/Tutorial:_Umsetzung_der_EU-Verbraucherrichtlinie_vom_13.06.2014#Template_Dateien_.C3.A4ndern
    [...]
    [...]

    Hallo,
    peinlich peinlich, das habe ich garnicht gelesen.

    Danke

    Hah

    • Neu im Forum
    • Beiträge: 1
    Hallo zusammen,
    ich verstehe das irgendwie nicht "so ganz" mit dem neuesten Update.
    Im Adminbereich war der Hinweis, daß man sich kurzfristig entschlossen hat, ein Update bereitzustellen.
    Das geht ja um die SEPA-Integration und wichtig die Widerrufsintegration.
    Da habe ich alles exakt so gemacht aber es existiert keine update.php, demzufolge das dann auch nicht passiert.
    Das einzige, was ich mir vorstellen kann ist, daß es damit zu tun hat,daß ich die Shopinstallation direkt von meinem Provider aus habe gemacht (das geht da per Knopfdruck).
    Kann mir allenfalls denken, daß das Update das "merkt", aber nicht wirklich logisch für mich.
    Kann jemand dazu vielleicht was sagen?
    Vielen Dank schon mal.

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Von welcher Version hast du denn aktualisiert? Wo steht denn in der Update-Anleitung etwas von einer "update.php"? :-?

    Grüße

    Torsten

    Angeal

    • Fördermitglied
    • Beiträge: 410
    • Geschlecht:
    Hey Tomcraft,
    das wurde zwar vor einigen Beiträgen schon mal erwähnt, aber in der Übersicht zu diesem Thread heißt es "SP1b"
    Aber es ist bei den Downloads immer nur von "SP1" die Rede. Um Verwirrungen zu vermeiden, sollte man das eventuell ändern ;-)

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    Ach herje... das ist mir gar nicht aufgefallen!
    Ich werde das Thema sofort umbenennen. Sorry für die Verwirrung! :sorry:

    Grüße

    Torsten

    oneQ

    • Viel Schreiber
    • Beiträge: 841

    Nur sind nun nach dem Import der Datenbankdatei alle Umlaute einem ?-Fragezeichen gewichen.
    Habe ich einen Fehler beim Import der Datenbank gemacht?


    Besteht das Problem immernoch? Schon probiert die Wiederherstellung der DB über das Backend (admin/backup.php) laufen zu lassen?

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Hallo zusammen,

    und vielen Dank für die vielen Hinweise.
    Ich habe nun das Datenbank Update erneut über das Backend eingespielt und nun sind die Sonderzeichen wieder so wie sie sein sollen.

    Ich glaube, die EU-Hektik hat viele von uns Arbeit und Nerven gekostet und gerade uns Anfängern, die dazu erst Recht keine Programmierer sind, vor besondere Herausforderungen gestellt.
    Wie ich im Forum gelesen habe, haben viele - ich nenne sie mal ´Fortgeschrittene modified Anwender´- Tipps, Anleitungen und sogar Module der Community zur Verfügung gestellt. Dass da im Eifer und beim gebotenen Zeitdruck mal Fehler unterlaufen ist völlig normal. Aber wie ich gerade in diesem Thread festgestellt durfte, durch ein funktionierendes Miteinander auch behebbar.

    Dafür meinen Dank an alle die dazu, auch mit ihren Beiträgen zur Richtlinien-Thematik, beigetragen haben!

    Nun muss ich nur noch das shop6 Template anpassen - und hoffe, dass ich da ohne Probleme zum gewünschten Ziel komme.

    Beste Grüße ins Forum
    Rosco

    Rosco

    • Neu im Forum
    • Beiträge: 44
    Ein hab´ ich noch...

    Templates (Shop6) sind auch angepasst  - soweit alles gut.

    Ich hatte im Content-Manager eine neue Seite ´Widerspruchs-Formular´ angelegt und hoffte hier das Formular als ´Muster-Widerrufsformular.pdf´ Datei zu hinterlegen.

    Egal, ob ich es vom PC her hochlade oder es über das Backend aus dem Drop-Down Feld (/media/content/) auswähle:
    Zitat
    Parse error: syntax error, unexpected T_STRING in /domain.de/eshop/media/content/Muster-Widerrufsformular.pdf on line 344

    Bei Aufruf des dann im Frontent hinterlegten Links kommt dann eine leere Seite im Brauser.

    Ist das vielleicht noch ein Fehler - oder sitzt der wieder mal vor´m Bildschirm?

    Beste Grüße
    Rosco

    astaller

    • Fördermitglied
    • Beiträge: 663
    • Geschlecht:
    Hallo, seit der Installation des SP1 bekomme ich folgende Fehlermeldung, sobald ich bei einer Bestellung eine Auftragsbestätigung senden möchte (Lokal unter XAMPP).

    Code: PHP  [Auswählen]
    Fatal error: Cannot redeclare xtc_date_short() (previously declared in ...\admin\includes\functions\general.php:301) in ...\inc\xtc_date_short.inc.php on line 36

    Woran liegt denn das und wie kann ich dies beheben?

    MfG
    Achim S.

    Dato

    • Mitglied
    • Beiträge: 214
    Hallo,
    hast du auch den Mail Server eingerichtet unter XAMPP ?

    astaller

    • Fördermitglied
    • Beiträge: 663
    • Geschlecht:
    Hallo Dato,

    die Mails vom Kontaktformular und Bestellbestätigungen, Statusänderungen funktionieren alle!

    MfG
    Achim S.

    astaller

    • Fördermitglied
    • Beiträge: 663
    • Geschlecht:
    Hab den Fehler gefunden.

    In der "send_order.php" ca. Zeile 154 das hier auskommentieren und es funktioniert wieder.

    Suche:
    Code: PHP  [Auswählen]
    require_once (DIR_FS_INC.'xtc_date_short.inc.php');

    Ersetze mit:
    Code: PHP  [Auswählen]
    //require_once (DIR_FS_INC.'xtc_date_short.inc.php');

    MfG
    Achim S.

    mikeSo

    • Neu im Forum
    • Beiträge: 21
    Guten Tag - allerseits,

    ... der Link "thickBox-link" in der Produktdetailseite fuer die Lieferzeit-Seite im Frontend funktioniert(e) nicht.

    Ich bin auf die Ursache gestossen.

    Es liegt an der "function getShippingStatusName($id, $link=false)" in der /includes/classes/main.php

    Die Variable "$link" muss auf "true" stehen - dann funktioniert auch "thickBox-link" fuer die Lieferzeit im Frontend :)

    Ich habe also die folgende Zeile:

    Code: PHP  [Auswählen]
    function getShippingStatusName($id, $link=false) {

    mit folgender Zeile ERSETZT:

    Code: PHP  [Auswählen]
    function getShippingStatusName($id, $link=true) {

    ---------------------------------------------------------

    Die datei "main.php" liegt im updatePaket
    (modified-shop_1.06-r4642_to_modified-shop_1.06-r4642_SP1_update\shoproot\includes\classes)

    ---------------------------------------------------------

    Ich hoffe es hilft den Einen oder Anderen hier ;)

    g, mike

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.650
    • Geschlecht:
    [...]
    ... der Link "thickBox-link" in der Produktdetailseite fuer die Lieferzeit-Seite im Frontend funktioniert(e) nicht.

    Ich bin auf die Ursache gestossen.

    Es liegt an der "function getShippingStatusName($id, $link=false)" in der /includes/classes/main.php

    Die Variable "$link" muss auf "true" stehen - dann funktioniert auch "thickBox-link" fuer die Lieferzeit im Frontend :)

    Ich habe also die folgende Zeile:

    Code: PHP  [Auswählen]
    function getShippingStatusName($id, $link=false) {

    mit folgender Zeile ERSETZT:

    Code: PHP  [Auswählen]
    function getShippingStatusName($id, $link=true) {
    [...]
    Ich hoffe es hilft den Einen oder Anderen hier ;)
    [...]

    Nein, das ist nicht die Lösung! Die Lösung für dein Problem wäre gewesen dich an die Update-Anleitung für das Template zu halten. Hinterlegst du nun ein Bild für die Lieferzeiten, dann zerhaut es dir den Link! :!:

    Anweisung für das Update des Template, siehe: Tutorial: Umsetzung der EU-Verbraucherrichtlinie vom 13.06.2014

    Hab den Fehler gefunden.

    In der "send_order.php" ca. Zeile 154 das hier auskommentieren und es funktioniert wieder.

    Suche:
    Code: PHP  [Auswählen]
    require_once (DIR_FS_INC.'xtc_date_short.inc.php');

    Ersetze mit:
    Code: PHP  [Auswählen]
    //require_once (DIR_FS_INC.'xtc_date_short.inc.php');
    [...]

    Danke für den Hinweis! :thx:

    Anstatt die Zeile komplett auszukommentieren mache es lieber wie folgt:

    Suche in der "/send_order.php":

    Code: PHP  [Auswählen]
          require_once (DIR_FS_INC.'xtc_date_short.inc.php');

    und ersetze mit:

    Code: PHP  [Auswählen]
          if (!function_exists('xtc_date_short')) {
            require_once (DIR_FS_INC.'xtc_date_short.inc.php');
          }

    Ich habe diesen Fehler in den Download-Paketen korrigiert.

    Grüße

    Torsten

    Fubu

    • Mitglied
    • Beiträge: 155
    Hallo,
    welches download Paket wurde Aktuallisiert ?

    Ich habe es gerade runtergeladen und da steht immernoch folgendes
    Code: PHP  [Auswählen]
     // SEPA info required?
        if (!empty($rec['banktransfer_iban'])) {
          require_once (DIR_FS_INC.'xtc_date_short.inc.php');
          $smarty->assign('PAYMENT_BANKTRANSFER_CREDITOR_ID', MODULE_PAYMENT_BANKTRANSFER_CI);
          // set due date based on date_purchased and due_delay

    basti4u2009

    • Neu im Forum
    • Beiträge: 4
    Was ich nicht bei mir im Shop finde ist folgendes "Erweiterte Konfiguration" -> "Zusatzmodule" -> "Lieferzeit ID" die "Sprachgruppe" des zuvor angelegten Contents "Lieferzeit" angeben und auf "Speichern" klicken". Was ja unter Punkt 4 in der Updateanleitung steht.

    Red_one

    • Neu im Forum
    • Beiträge: 41
    • Geschlecht:
    ich glaube, ich habe einen kleinen Fiehler gefunden:

    im Bitte lesen-Ordner ist die Datei Update-Anleitung

    diese beginnt mit

    Stand: 04/2013
    ********************************************************
    Update von 1.06 rev 4642

    ist aber wohl vom Stand Juni 2014, oder?

    mich hats jedenfalls kurz irritiert.

    noRiddle (revilonetz)

    • Experte
    • Beiträge: 11.107
    • Geschlecht:
    @ basti4u2009
    Änderung in der /admin/includes/configuration_installer.php nicht durchgeführt ?

    Gruß,
    noRiddle

    sieghard

    • Fördermitglied
    • Beiträge: 38
    • Geschlecht:
    @ basti4u2009
    Änderung in der /admin/includes/configuration_installer.php nicht durchgeführt ?
    Just my two cents: Gestern abend hatte ich das r4642 SP1 (unerwartet) problemlos nach der Update-Anleitung in unserem Shop eingespielt. Da stand zwar nicht, dass zuerst alle Dateien aus dem ZIP-Archiv zu installieren sind, aber das wusste ich ja aus dem freundlichen Forum hier :-).
    Und die drei neuen PDFs waren auch schnell selber erstellt.

    Wenn man im Backend auf "Erweiterte Konfiguration" klickt, dann wird der neue Eintrag "Lieferzeit ID" ganz unten angezeigt.

    jannemann

    • modified Team
    • Beiträge: 6.288
    • Geschlecht:
    Hallo Community,

    in einem frisch installierten Shop habe ich die Artikelnummer mit im Warenkorb.
    Der Shop und die Datenbank sind frisch installiert und es wird das Standard Template verwendet.
    Kann jemand diesen Fehler bestätigen?

    Schöne Grüße,
    Jan

    ShopNix

    • Viel Schreiber
    • Beiträge: 1.208
    Das ist so, aber ich halte das nicht für einen Fehler. ;-)

    jannemann

    • modified Team
    • Beiträge: 6.288
    • Geschlecht:
    Hallo ShopNix,

    meinst du das wegen dem Smiley ironisch?  :-)

    Schöne Grüße,
    Jan

    ShopNix

    • Viel Schreiber
    • Beiträge: 1.208
    Kennst Du nicht den alten Scherz?

    It's not a bug, it's an undocumented feature.

    Fakt ist, dass ich irgendwann die Artikelnummer auf Kundenwunsch nachträglich eingebaut habe. Ich halte das also keineswegs für einen Fehler, sondern für einen Zusatznutzen.

    Der Smiley galt also nicht dem Programm, sondern dem Scherz.

    jannemann

    • modified Team
    • Beiträge: 6.288
    • Geschlecht:
    Hallo ShopNix,

    danke für die Aufklärung  ;-)
    Wäre es nicht besser, wenn man dann noch zusätzlich vor die Artikelnummer das Wort "Artikel-Nr." anzeigen lässt?

    Schöne Grüße,
    Jan

    ShopNix

    • Viel Schreiber
    • Beiträge: 1.208
    Als Teammitglied sollte Dir die künftige Version zur Verfügung stehen. Dort könntest Du ggfls nachschauen, ob wir an dieser Stelle möglicherweise in den Genuss eines Backports kommen.

    Aber sei's drum: Eine Bezeichnung für das Feld einzuführen ist eine minimale Änderung im Template, daher verzichte ich aus reiner Faulheit darauf, mir darüber eine qualifizierte Meinung zu bilden.

    oneQ

    • Viel Schreiber
    • Beiträge: 841
    Wäre es nicht besser, wenn man dann noch zusätzlich vor die Artikelnummer das Wort "Artikel-Nr." anzeigen lässt?

     :pro:

    lithoverlag

    • Fördermitglied
    • Beiträge: 593
    • Geschlecht:
    Hi
    habe das Update von 1.06 auf rev 4642 duchgezogen...
    bei Punkt 4 "Im Admin-Backend unter "Erweiterte Konfiguration" -> "Zusatzmodule"" meldet das System:

    1048 - Column 'set_function' cannot be null

    INSERT INTO configuration (configuration_id ,configuration_key ,configuration_value ,configuration_group_id ,sort_order ,last_modified ,date_added ,use_function ,set_function) VALUES (NULL, 'SHIPPING_STATUS_INFOS', '', 17, 14, NULL, NOW(), NULL, NULL);

    [MOD SQL Error]

    Was habe ich falsch gemacht?

    lithoverlag

    • Fördermitglied
    • Beiträge: 593
    • Geschlecht:
    Der fehler tritt im Adminbereich bei allen Menübefehlen auf die die admin/configuration.php aufruft...

    lithoverlag

    • Fördermitglied
    • Beiträge: 593
    • Geschlecht:
    GELÖST... sorry. Bitte kann wegen Blödheit gelöscht werden. Warum sich aber die Set_funktion auf NICHT NULL gesetzt hat - keine Ahnung. Habe einen alten Thread gefunden wo es um eine modernisierte XTC Anwendung ging... was bei mir nicht der Fall ist. War eine 1.05 Neuinstallation, die bis zum SP1 auf dem aktuellen Stand war.

    By the way - Die Suche über Google trifft bessere Suchergebnisse als die Suche hier im Forum. Und Google bringt mich dann wieder hier ins Forum zurück...

    Slevin

    • Neu im Forum
    • Beiträge: 15
    • Geschlecht:
    Hmm, ich habe meine Templates, Sprachpakete  usw vielen Änderungen unterzogen. Ebenso einige betroffene php-Dateien sind bereits meinen Vorstellungen angepasst und um einge eigene Funktionen erweitert.

    Diese Dateien einfach zu überschreiben und nach Anleitung zu updaten lässt meinen ganzen Shop in die Röhre sehen.

    Gibt es zum SP1 keine todo-liste, welche Codezeilen verändert wurden bzw. angepasst werden müssen?

    noRiddle (revilonetz)

    • Experte
    • Beiträge: 11.107
    • Geschlecht:
    Dein Anliegen ist ein Widerspruch in sich.
    Die Tatsache, daß die Download-Paket-Ersteller nicht wissen können was der Einzelne so alles in seinen Codes verändert hat, ist ein "suche Zeile soundso und ersetze sie mit soundso" nicht möglich.

    Lade dir das Download-Paket "Update 1.06 rev 4642 zu 1.06 rev 4642 SP1" von hier runter und mache das Update mittels Datei-Vergleich mithilfe eines geeigneten Programmes.

    Gruß,
    noRiddle