Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: Ausgeloggt ist die Such-Box da, eingeloggt mit SSL ist sie weg ?!

    matz

    • Mitglied
    • Beiträge: 171
    Hallo zusammen,

    ich habe leider ein Problem mit der Suchfunktion.
    Wenn ich ausgeloggt die Seite betrete, ist die Suchfunktion da und funktioniert auch wunderbar.
    Logge ich mich nun ein, werde ich zur Hauptseite mit eingeschaltetem SSL geleitet.
    Aber ab dem Moment ist die Suchbox nicht mehr da.

    Hat jemand von Euch vielleicht einen Lösungsansatz wo ich da nachschauen könnte?

    http://tinyurl.com/cp4yd3w

    Gruß Matz

    [EDIT UT2K3 16.05.2011: Link auf Wunsch gekürzt.]

    Linkback: https://www.modified-shop.org/forum/index.php?topic=16856.0

    franky_n

    • Experte
    • Beiträge: 4.950
    Hallo Matz,

    wenn ich die Seite per https:// aufrufe ist die Suche da.
    Kann es sein das Dein Browsercache Dir da einen Streich spielt?

    Ansonsten liegt es sicherlich nicht am https sondern eher daran das man eingeloggt ist...

    Viele Grüße

    Franky

    matz

    • Mitglied
    • Beiträge: 171
    Stimmt, wenn man direkt das HTTPs mit eingibt wirds auch angezeigt.
    Also ergo muss es am "Einloggen" liegen. Aber warum?!  :silly: ...werden ja doch auch nur die normalen Templates geladen wie vorher  :-?

    Am Cache liegt es nicht - habe es an mehreren PCs getestet und auch alle caches geleert und auf 0MB gesetzt.

    Komisch.

    techway

    • Experte
    • Beiträge: 163
    Hallo,

    poste mal deine "index.html" aus deinem Template.

    Ich vermute dass in diesem Bereich was nicht stimmt:

    Code: PHP  [Auswählen]
    <li><a href="http://www.tld.de/index.php">Startseite</a></li>
    <li><a href="https://www.tld.de/create_account.php">Neukunde?</a></li>            
    <li><a href="https://www.tld.de/account.php">Ihr Konto</a></li>
    <li><a href="https://www.tld.de/shopping_cart.php">Warenkorb</a></li>
    <li><a href="https://www.tld.de/checkout_shipping.php">Kasse</a></li>
    <li><a href="https://www.tld.de/login.php">Anmelden</a></li>
    <li><div id="searchbox"><form id="quick_find" action="http://www.tld.de/advanced_search_result.php" method="get">

    Und zwar beim "Anmelden"-Link ist evtl. das {/if} verrutscht und schließt die Suchbox mit ein.

    Gruß
    TechWay

    [EDIT UT2K3 16.05.2011:Link auf Wunsch entfernt]

    matz

    • Mitglied
    • Beiträge: 171
    [...]
    Und zwar beim "Anmelden"-Link ist evtl. das {/if} verrutscht und schließt die Suchbox mit ein.
    [...]

    Hallo Techway,

    vielen Dank, genau das war das Problem. Das {/if} hat die Suchbox mit eingeschlossen.
    Nun geht es wieder... :)

    Dankeschön für den Hinweis.

    Gruß Matz