Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
    Spenden
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:
    Spenden
  • Thema: Sofortüberweisung geht nicht mehr nach Passwortänderung

    flashlight

    • Fördermitglied
    • Beiträge: 8
    Hallo,

    ich habe von Sofort.com eine Info bekommen, dass die Passwörter für Sofortüberweisung bis zum 21.10.11 neu gesetzt werden müssen.
    Habe ich auch gemacht, aber seitdem funktioniert die Zahlung mit Sofortüberwesiung nicht mehr.
    Abbruch mit folgender Meldung:

    Zitat
    Der übergebene Input-Hash stimmt nicht mit dem von uns berechneten Input-Hash überein. Wenn Sie der Shopbetreiber sind, überprüfen Sie bitte, ob das in Ihrem Shopsystem gespeicherte Projektpasswort mit dem Projektpasswort in den Projekteinstellungen Ihres Anbietermenüs übereinstimmt.

    Passwörter sind bei Sofortüberweisung und bei XTC identisch.
    Auf der Seite von Sofortüberwesiung habe ich schon folgende Parameter eingestellt.
    Passwortgenerierung ohne Sonderzeichen
    Hash auf SHA1 eingestellt.

    Hat jemand ein ähnliches Problem nach Passwortänderung, und evtl. eine Lösung?

    Gruss
    Holger

    Linkback: https://www.modified-shop.org/forum/index.php?topic=15726.0

    ut2k3

    • Moderator
    • Beiträge: 497
    • Geschlecht:
    Re: Sofortüberweisung geht nicht mehr nach Passwortänderung
    Antwort #1 am: 01. Oktober 2011, 09:45:58
    Hallo Holger,

    hast du das Passwort dann auch in deinem Modul geändert? Oft schleicht sich da ein Leerzeichen oder ähnliches beim kopieren ein.

    Rob

    Matt

    • Experte
    • Beiträge: 4.241
    Re: Sofortüberweisung geht nicht mehr nach Passwortänderung
    Antwort #2 am: 01. Oktober 2011, 11:29:34
    Keine Probleme hier in drei Shops. SHA256 mit Sonderzeichen.

    Tomcraft

    • modified Team
    • Gravatar
    • Beiträge: 44.080
    • Geschlecht:
    Re: Sofortüberweisung geht nicht mehr nach Passwortänderung
    Antwort #3 am: 01. Oktober 2011, 15:15:31
    Wenn du das Passwort änderst, dann musst du auch den Hash in modified eCommerce Shopsoftware ändern! Lass einfach nochmal den Autoinstaller durchlaufen, der richtet dir das dann wieder. ;-)

    Da es kein Fehler ist, verschiebe ich es von "Bugs oder Funktionsfehler" nach "Admin- und Shopbereich".

    Grüeß

    Torsten
    anything