Neuigkeiten
  • Die modified eCommerce Shopsoftware ist kostenlos, aber nicht umsonst.
  • Damit wir die modified eCommerce Shopsoftware auch zukünftig kostenlos anbieten können:

Autor Thema: MODUL: janolaw AGB Hosting-Service für modified eCommerce Shopsoftware  (Gelesen 47843 mal)

Offline Tomcraft

  • modified Team
  • *****
  • Gravatar
  • Beiträge: 42.742
  • Geschlecht: Männlich
    • Teile Beitrag
    • http://www.modified-shop.org
Re: MODUL: janolaw AGB Hosting-Service für modified eCommerce Shopsoftware
« Antwort #90 am: 10. Februar 2014, 23:50:14 »
Ich habe das Modul in Beitrag 1 auf die neueste Version aus unserem SVN aktualisiert.

Ich freue mich über Feedback.

Grüße

Torsten

Offline the traveller

  • Fördermitglied
  • *****
  • Beiträge: 63
  • Geschlecht: Männlich
    • Teile Beitrag
Hallo,

ich habe heute das Modul entsprechend der Anleitung eingebaut. Es wird korrekt im Backend gezeigt und ich habe die Notwendigen Daten meines janolaw Accounts eingetragen. Setzte ich dieses Modul auf true wird der Shop nicht mehr angezeigt bzw. es kommt im Frontend nur noch eine weiße Seite. Ich konnte den Fehler auf die Datei ...includes\application_top.php eingrenzen.

Dort soll die Datei um

Code: PHP  [Auswählen]
// BOF - Tomcraft - 2011-06-17 - Added janolaw AGB hosting service
if (defined('MODULE_JANOLAW_STATUS') && MODULE_JANOLAW_STATUS == 'True') {
  require_once(DIR_FS_EXTERNAL.'janolaw/janolaw.php');
  $janolaw = new janolaw_content();
}
// EOF - Tomcraft - 2011-06-17 - Added janolaw AGB hosting service

ergänzt werden. Nehme ich diese Ergänzung raus läuft der Shop wieder.
Die Funktion PHP_allow_url_fopen ist aktiv! Mein Shop ist ein 1.05er SP1d.

Kann mir jemand damit helfen? Ich komm nicht weiter  :paperbag:

Grüße Jürgen

Offline Bonsai

  • Viel Schreiber
  • *****
  • Beiträge: 4.147
  • Geschlecht: Männlich
    • Teile Beitrag
    • J.K.Fischer Shop
existiert die Datei janolaw/janolaw.php dort auch? Also ...includes/janolaw/janolaw.php

Schuss ins blaue, aber jedes mal wenn mir mein Shop nur noch weiße Seite angezeigt hatte fehlte eine Datei die mit require, require_once oder include aufgerufen wurde.

Offline the traveller

  • Fördermitglied
  • *****
  • Beiträge: 63
  • Geschlecht: Männlich
    • Teile Beitrag
Ja die exisitert. Habe alle Dateien überprüft, alles da wo es sein soll.
Der Support von janolaw meinte es liegt daran das die AGB/Impressum/Widerruf Dateien noch nicht auf meinem Webspace liegen. Dieser Ordner enthält tatsächlich (...media/content) keine Dateien von janolaw. Die Dateien sind aber per Direktaufruf (janolaw.de/shop/user_id/shop_id...ect) bei janolaw erreichbar.
Auch die Verzeichnisrechte passen, alles 777. Ich wies jetzt nicht wie lange das Modul braucht um sich die Daten zu ziehen. Liegt es daran das die Texte noch nicht verfügbar sind?

Vielen Dank für den bisherigen Hinweis  :-D

Jürgen

Offline the traveller

  • Fördermitglied
  • *****
  • Beiträge: 63
  • Geschlecht: Männlich
    • Teile Beitrag
Hab gerade gesehen das die order_mails korrekt verschickt werden. Sprich inkl. der Widerrufsbelehrung von jano. (Obwohl das Modul offline ist??!!) Auf dem Webspace liegt nach wie vor nichts.

Grüße

Offline the traveller

  • Fördermitglied
  • *****
  • Beiträge: 63
  • Geschlecht: Männlich
    • Teile Beitrag
Moin moin,

darf ich noch mal *pushen*? Hatte bisher keiner ein solches Problem?
Der Support von jano konnte mir bisher auch nicht helfen. Ich bin absolut Ratlos woran es liegen könnte. Habe mich exakt an die Anleitungen gehalten.

Grüße

Offline Tomcraft

  • modified Team
  • *****
  • Gravatar
  • Beiträge: 42.742
  • Geschlecht: Männlich
    • Teile Beitrag
    • http://www.modified-shop.org
Melde dich mal bitte per Mail bei mir, dann schaue ich mir das mal bei dir im Shop an.

Nachtrag: Fehler gefunden.

Such in der "/includes/application_top.php":

Code: PHP  [Auswählen]
  require_once(DIR_FS_EXTERNAL.'janolaw/janolaw.php');

und ersetze mit:

Code: PHP  [Auswählen]
  require_once(DIR_FS_CATALOG.'includes/external/janolaw/janolaw.php');

Ich habe das Modul in Beitrag 1 entsprechend aktualisiert.

Grüße

Torsten

Offline the traveller

  • Fördermitglied
  • *****
  • Beiträge: 63
  • Geschlecht: Männlich
    • Teile Beitrag
Ha, das ging ja rasant! Läuft! Genau das war der Fehler! Bin begeistert und darf mich ganz herzlich bedanken!!!  :thx:

Grüße

Jürgen

Offline Tomcraft

  • modified Team
  • *****
  • Gravatar
  • Beiträge: 42.742
  • Geschlecht: Männlich
    • Teile Beitrag
    • http://www.modified-shop.org
Ich bedanke mich für die Meldung des Fehlers! :thx:

Grüße

Torsten

Offline SpaceGrobi

  • Neu im Forum
  • *
  • Beiträge: 2
    • Teile Beitrag
...
muss man das Modul auch installieren wenn man die Version 1.06 des Modified Shops auf dem Server drauf hat??

Ich habe mir mal die PHP Dateien und die Hinweise zu den zu erledigenden Veränderungen angesehen. Die Hinweise passen leider so gar nicht zu den vorhandenen Dateien auf dem Server. ...
Hallo zusammen,
wurde diese Frage schon beantwortet? - Ich habe das gleiche Problem... oder stehe gerade voll auf'm Schlauch...  :silly:
Danke für Eure Hilfe!
Gruß SpaceGrobi

Offline Bonsai

  • Viel Schreiber
  • *****
  • Beiträge: 4.147
  • Geschlecht: Männlich
    • Teile Beitrag
    • J.K.Fischer Shop
Hab zwar keinen Plan von dem Modul, aber in meiner 1.06 habe ich im Adminbereich unter Module im vorletzten Menüeintrag das Modul drin.

Offline SpaceGrobi

  • Neu im Forum
  • *
  • Beiträge: 2
    • Teile Beitrag
Danke Bonsai. Das vorhandene Modul welches Du siehst ist veraltet (hab ich auch) und muss upgedatet werden, aber die "Changed Files" gibt es so nicht wie in der Anleitung beschrieben (bzw. es gibt teilweise die zu ergänzenden Inhalte nicht).

Offline lohkaes1

  • Schreiberling
  • ****
  • Beiträge: 497
    • Teile Beitrag
Hallo,

kurze Frage: wurde bei jemand schon automatisch die AGBs, Widerruf etc. upgedatet?
Bitte um kurze Info. Danke.

Gruß

Offline nashsx

  • Neu im Forum
  • *
  • Beiträge: 35
    • Teile Beitrag
Hallo,

also bei mir ist es ganz merkwürdig, die Anleitung entspricht nicht meinen Dateien auf dem Server, aber erstmal möchte ich das Problem präzisieren:

Das Modul sieht schon mal nicht aus wie in der Anleitung zur Einbindung bei janolaw angegeben, siehe angehängtes Bild.

[ Für Gäste sind keine Dateianhänge sichtbar ]

Da im Backend steht, man solle die Versionen der Module auf Aktualität überprüfen, dachte ich mir, es ist vermutlich veraltet. Also habe ich hier nachgesehen und die aktuellste Version gedownloaded, und in der Anleitung soll ich einige Dateien verändern, aber schon in der ersten fängt die Schwierigkeit an, die Code-Stellen, hinter denen ich den zusätzlichen angegebenen Code einfügen soll, existieren einfach nicht.
Gleich bei der ersten Datei, Beispiel application_top.php:

Zitat
Nach Z.157:

Code: PHP  [Auswählen]
  // BOF - web28 - 2010-05-06 - PayPal API Modul
  define('FILENAME_PAYPAL','paypal.php');
  define('FILENAME_PAYPAL_CHECKOUT', 'paypal_checkout.php');
  // EOF - web28 - 2010-05-06 - PayPal API Modul

das einfügen:

Code: PHP  [Auswählen]
  // BOF - Tomcraft - 2011-06-17 - Added janolaw AGB hosting service
  define('FILENAME_JANOLAW','janolaw.php');
  // EOF - Tomcraft - 2011-06-17 - Added janolaw AGB hosting service

Die oben angegeben Zeilen existieren in meiner application_top.php nicht, und so geht es mit den weiteren Dateien, die zu ändern sind, weiter.
Ich habe dabei übrigens nicht einfach die notepad-Suchfuntion benutzt, sondern die ganzen Dateien jeweils mit eigenen Augen nach übereinstimmendem Code abgesucht, und nichts gefunden.

Kann mir da einer helfen?
Ich habe einen janolaw-Zugang mit automatischer Aktualisierung, und diese möchte ich auch gerne gemäß den beworbenen Leistungen nutzen, leider ist mir dies mit den zur Verfügung stehenden Anleitungen nicht möglich.

Vielen, vielen Dank im Voraus!

Shopversion:
modified eCommerce Shopssoftware v1.06 rev 4642 dated: 2013-04-20
Datenbank Version: "MOD_1.0.6.0"

Offline Tomcraft

  • modified Team
  • *****
  • Gravatar
  • Beiträge: 42.742
  • Geschlecht: Männlich
    • Teile Beitrag
    • http://www.modified-shop.org
Bitte aktualisiere das Modul in deinem Shop mit der Version aus Beitrag 1.

Grüße

Torsten

Shop Hosting

Teile per facebook Teile per linkedin Teile per twitter